junk mail controls on IMAP shared folders causes many "permission denied" popups

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: bnies, Assigned: Bienvenu)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030530
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030530

Precondition: A user has subscribed to some IMAP shared folders with no write
permission and junk mail controls enabled for that IMAP account.

When new mail arrives in those write protected folders or he subscribes to a
folder with new messages and junk mail control detects some potential junk mail
it wants to store junk information on the IMAP server which is not permitted.
Network traffic:

56 uid store 40 +FLAGS (Junk)
56 NO Permission denied
57 uid store 40 -FLAGS (NonJunk)
57 NO Permission denied
58 UID fetch 40 (UID RFC822.SIZE BODY.PEEK[])

The results are many annoying "The current command did not succeed. The mail
server responded: Permission denied" popups which the user has to click away.
Since there is no explanation what causes these errors the user gets very confused.

Fixes: 
1) Disable junk mail controls for write protected folders.
--or--
2) Store junk information for write protected folders in local client.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

15 years ago
can you attach an imap protocol log? thx.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

15 years ago
Hmm ... I can no longer reproduce that problem anymore with the final Mozilla
1.4 release. Now it only gives an error popup when I have the "Move to Junk
folder" option enabled and this behaviour is correct since the client does not
have delete permission on the IMAP server. 

When I reported this problem I had this option disabled and it complained when
just wanted to store the junk flag.
(Reporter)

Comment 3

15 years ago
Weird ... using the same build (Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4)
Gecko/20030530) I still can't reproduce the problem ... maybe it's too hot in
the office ...
(Assignee)

Comment 4

15 years ago
oh, you know, I think I fixed it so that we don't run the junk mail controls on
shared folders.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.