If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Flash plugin does not render with 100% width and height (in object tag) and XHTML DTD

RESOLVED DUPLICATE of bug 237113

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 237113
15 years ago
5 years ago

People

(Reporter: Dylan Smith, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The plugin will not render in Mozilla browsers with XHTML DTD and 100%
width/height. Take out the DTD (i.e. begin the page with <html>) and it works
fine, or change the width to 650, height to 450 (leave DTD as is) and it works fine.

Please note: my "custom" (XHTML conformant) object tag does not affect this bug.

Reproducible: Always

Steps to Reproduce:
1. Begin a document with XHTML DTD
2. Insert a plugin (I'm using Flash) using 100% width/height
3. Swap these out as described in details: either take out the XHTML DTD and
just enter <html> or use fixed width/height

Actual Results:  
The plugin will not render unless one of these two conditions is met.

Expected Results:  
Plugin should be rendered at 100% width, 100% height in a fully conformant XHTML
document.
(Reporter)

Comment 1

15 years ago
In another example, (http://www.foliomedia.com/index3.htm), which uses a more
standard (though invalid) <object><embed></embed></object> method, I got Phoenix
(0.6) to render a small portion of the plugin incorrectly, (NS 7 still does not
render it at all).

Comment 2

14 years ago
*** Bug 227229 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
This occurs with any DTD, not just XHTML. For example the page at http://www.3rd-wave.net/client/
blackbird/site2/ uses an HTML4.01 DTD and specifies the Flash player in percent, and the result is a 
miniscule Flash movie. Removing the DTD and/or specifying the Flash player in pixels are potential 
workarounds.

Comment 4

14 years ago
For the moment, in this new landscape of XHTML, the suggestion
of using CSS is currently the best way to fix the 100% percent
issue in the object height attribute when a full Flash web site
is desired.

<style type="text/css">
html, body { margin: 0; padding: 0; height: 100%; }
</style>

Also review the RazorX comments for the 100% Flash issue
on alistapart.com:

http://www.alistapart.com/discuss/flashsatay/25/

http://www.alistapart.com/discuss/flashsatay/26/

http://www.alistapart.com/discuss/flashsatay/27/


Comment 5

13 years ago
*** Bug 270433 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 264474 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
This bug is invalid, see bug 237113, comment 2 - 3

*** This bug has been marked as a duplicate of 237113 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.