From the Start menu select Help & Support and a blank window appears

VERIFIED FIXED in mozilla1.4final

Status

VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: nbaca, Assigned: neil)

Tracking

({regression})

Trunk
mozilla1.4final
x86
Windows ME
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Trunk and branch build 2003-06-05: WinMe

Overview: Select the Help & Support menu item off of the Start menu and it opens
a blank window.

Steps to reproduce:
1. Install the latest build
2. Select Start|Programs|Netscape|Help & Support
3. If the profile manager appears then select a profile

Actual Results: A blank Help window screen appears.

Expected Results: A populated Help window should appear similar to selecting
Help|Help & Support Center from the Navigator window or pressing the F1 key.
(Reporter)

Comment 1

16 years ago
Marking nsbeta1 so this bug is fixed for this release.
Keywords: nsbeta1

Comment 2

16 years ago
this is the output in the console that I'm getting when I manually type the
following in the url bar:
  chrome://help/content

JavaScript strict warning:
chrome://help/content/help.js line 99: reference to undefined property
window.arguments

JavaScript error:
chrome://help/content/help.js line 99: window.arguments has no properties

Document chrome://help/content/help.xul loaded successfully

Comment 3

16 years ago
this might have been regressed by the fix to bug 195888.

cc:ing neil to see if he has any clues on the cause of this.
(Assignee)

Comment 4

16 years ago
Do you know what the command line for that item is?
(Assignee)

Comment 5

16 years ago
Created attachment 125078 [details] [diff] [review]
Proposed patch

I wrote this patch to work both with -chrome chrome://help/content/ and also
[JS console] openDialog('chrome://help/content','','chrome,all,dialog=no'), and
also tested it to make sure the "Help" button in editor image properties still
works.

Comment 6

16 years ago
reassigning to neil since he's got a patch.
Assignee: ssu → neil.parkwaycc.co.uk

Comment 7

16 years ago
adt: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+, regression
Whiteboard: [adt2]

Comment 8

16 years ago
Comment on attachment 125078 [details] [diff] [review]
Proposed patch

I get the following error when I enter 'chrome://help/content' manually in the
browser url bar:
  JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://help/content/help.js :: init :: line 118"  data: no]

However, I don't think people will doing this anyways.	I would consider this
as an edge case.

otherwise, the patch looks good.

r=ssu
Attachment #125078 - Flags: review+
ssu, do you want to drive this in to 1.4 and the trunk?

seems worth taking to me.
Target Milestone: --- → mozilla1.4final

Comment 10

16 years ago
Comment on attachment 125078 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to the 1.4 branch.
Attachment #125078 - Flags: approval1.4+

Comment 11

16 years ago
patch checked in to both trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.4
Resolution: --- → FIXED

Comment 12

16 years ago
qa to reporter nbaca
QA Contact: bugzilla → nbaca

Comment 13

16 years ago
Using branch build 20030612 on winxp this is fixed. verified in branch
Note:tested on winxp because I saw the problem with builds before fix.
Keywords: verified1.4
(Reporter)

Comment 14

16 years ago
Trunk build 2003-06-12: Win2k
Verified Fixed.
Status: RESOLVED → VERIFIED

Comment 15

16 years ago
Removing fixed1.4 keyword since fix has been verified on the branch by Esther
Keywords: fixed1.4
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.