Large mail headers push message off screen.

RESOLVED DUPLICATE of bug 41994

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED DUPLICATE of bug 41994
15 years ago
14 years ago

People

(Reporter: Martin Glaude, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

This image demonstrates the problem:
http://www.deskslave.org/bugzilla/mozilla-mail-header-bug2.gif

When viewing a message with "All Headers" view enabled, the content of a mail
message with a large number of headers gets pushed off screen.

No scrollbars are available to be able to see the remainder of the headers or
the mail message itself.

Reproducible: Always

Steps to Reproduce:
1.  From the "View" menu enable "Headers->All"
2.  Select an e-mail with a large header block.  (>24 lines at 1024x768)
3.  Ensure that the headers are expanded (The "tree" box has a minus in it.)
4.  Collapse the headers to a single line by click the minus into a plus on the
tree control.
5.  Note that the mail message and some of the headers may be unavailable.


Expected Results:  
Minimally, provide a scrollbar to see the remainder of the headers and perhaps
the mail message content as well.

Perhaps the mail headers should be confined to be "X" lines high and scrollbars
appear when that limit is exceeded.

Obviously, the simple workaround is to collapse the "All Headers" view to be
able to see the error message.  However, this does not enable you to see any
mail headers which had been pushed off screen.

This is related to bug #208473 (http://bugzilla.mozilla.org/show_bug.cgi?id=208473)

Comment 1

15 years ago
Reporter, when you read the duplicate, you'll see that the hidden message body 
is the least of the problems when the header pane is too tall for the window.

See also bug 91662, a similar bug relating to a too-wide header pane.  It 
doesn't appear there is a solution on the horizon for either.  Some additional 
bugs about this problem: bug 56825, bug 151831, bug 166892.

*** This bug has been marked as a duplicate of 41994 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.