HTTP Upload fails to upload images (maybe other files too) to forums (Firebird)

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: TychoQuad, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030603 Mozilla Firebird/0.6

Attempting to upload images to forums (such as avatars) fails to work. after
filling out the form and hitting the Send/save/complete button, the browser
begins to load, but doesn't actually do anything. after about 5 mins, it gives
up, still in the settings page.

Tested on 2 different forums, vBB and phpBB. Results were the same both times.

Reproducible: Always

Steps to Reproduce:
1. go to a forum that supports uploading avatars from your own PC.
2. go to the settings/prefrences page and browse your HDD for a supported avatar
to use.
3. hit submit button.

Actual Results:  
page appears to load, but nothing actually happens. the browser should stop
pretending to load after about 2 mins. nothing has changed since you hit the
submit button.

Expected Results:  
loaded the page, and submitted your avatar.

Comment 1

15 years ago
Do you have any extensions like TBE installed?  On the forums someone said it
works with TBE disabled.

Comment 2

15 years ago
I can reproduce this bug even after disabling TBE on 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030603 Mozilla
Firebird/0.6 .

Comment 3

15 years ago
BTW, the product is Phoenix, not Browser.

Comment 4

15 years ago
Other info: OS=All and title->HTTP Upload Broken as other files can't be
uploaded either.

Comment 5

15 years ago
Why is this OS All?  Has it been verified on non-Windows?  I don't have any
problems with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030611 Mozilla Firebird/0.6 and I do have TBE

Comment 6

15 years ago
works for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030731 Mozilla
Firebird/0.6.1

Comment 7

15 years ago
Issue remains.  Can not upload a file.

An observation - something to do with passing the pathname?.

Using a simple form upload script the following happens:

an IE form submission returns:
File uploaded:  D:\temp\dra-email.tif 
Filename: dra-email.tif

a Mozilla form submission returns:
File uploaded:  bookmarks.htm 
Filename: 

Oh yea:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Comment 8

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030803
Mozilla Firebird/0.6.1

Is this a clean build and new profile?

Saying "issue remains" and using a build that is more than a month old is an
inconsistancy.

Comment 9

15 years ago
Upload a Image works great!
(on mozillazine.org) a JPG of 100x100 pixels. No problem!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7

Comment 10

15 years ago
Taking QA.
QA Contact: general → 9quawbieby0001

Comment 11

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031003
Firebird/0.7
uploading a png (from a path with a space in it, too) to the forums.

Marking as such.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.