Cannot save a static link (PDF file) via Save Target Link, but views fine in web browser when single-clicked

RESOLVED DUPLICATE of bug 160448

Status

--
major
RESOLVED DUPLICATE of bug 160448
16 years ago
3 years ago

People

(Reporter: seanmchale, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Trying to download the Instruction Manual PDF from:
http://www.marineland.com/products/commercial/retail/mars_vertical.asp

When I single-click on the file, it pulls up the Acrobat plugin and displays the
PDF as expected.  Now, if I try to right-click on the link, choose Save Link
Target As.., I get the error message "The link could not be saved. The web page
might have been removed or had its name changed."

Reproducible: Always

Steps to Reproduce:
go to http://www.marineland.com/products/commercial/retail/mars_vertical.asp
scroll down and RIGHT-click on the Download Manual button, and choose Save link
target as...

If I keep right-clicking and trying, eventually it does pop up the Save File
dialog box, but it shows "Vertical_Manual.pdf.html" as the filename, rather than
the Vertical_Manual.pdf filename that it should be.  If I opt to save at this
stage, the transfer does work correctly. 
Actual Results:  
I get the error message "The link could not be saved. The web page might have
been removed or had its name changed."

Expected Results:  
Should have provided me with a dialog box asking where I wanted to save the file
to.

Comment 1

16 years ago
This is most likely a duplicate of either bug 141740 or bug 160448.
->File Handling
Assignee: general → law
Component: Browser-General → File Handling
QA Contact: general → petersen

Comment 2

16 years ago
seeing this too on Win2k build 2003060508.
Depends on: 160454
(Reporter)

Comment 3

16 years ago
The only reason I posted this one, is that unlike bug# 160454, if I keep trying
the operation, it eventually DOES work, albiet wtih a wrong target filename as
Mozilla is automatically adding a .html extension to the target file name.  I'm
wondering if maybe this addition of .html at the end of the filenames is what is
causing Mozilla to choke on the request?  I don't have a packet sniffer on this
laptop, so no way to know exactly what is being sent out.

Comment 4

16 years ago
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604

Save Target works in IE6.

Comment 5

16 years ago
The server responds to moz's HEAD request with HTTP error 406 Not Acceptable.
The next time Moz sends a HEAD request it gets no responce(?).
After you select your location. Moz sends a normal GET request and receives the pdf.

The reason it has a .html on the end is that the last responce to the HEAD
request was text/html(because it sent an error page). 

The server is IIS 5.0 w/SecureIIS - http://www.eeye.com/SecureIIS/ .

Comment 6

16 years ago
I agree that it's a dupe of 160448.

Perhaps you should post your additional information (the fact that it eventually
worked) in that bug.

*** This bug has been marked as a duplicate of 160448 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.