Bug 208555 (viewpoint)

While trying to load the Viewpoint plugin, the browser crashes [@ NPVIEWPOINT ]

VERIFIED FIXED

Status

()

Core
Plug-ins
--
critical
VERIFIED FIXED
15 years ago
7 years ago

People

(Reporter: Nick, Assigned: Brian T. Doherty)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: viewpoint crash, crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

While trying to load the Viewpoint plugin at
http://www.foxmangames.com/phoenix.html (a plugin which lets people display 3D
models in real time on websites), Mozilla crashes.  I don't recall it working
with previous versions of Mozilla either.  http://www.schmedco.com produces this
error as well.

Reproducible: Always

Steps to Reproduce:
1. Start web browser
2. Travel through time to http://www.foxmangames.com/phoenix.html
3. Prepare for crash

Actual Results:  
A message box pops up saying:

"MetaStream 3 Plugin

The plugin performed an illegal operation.  you are strongly advised to restart
Navigator."

Expected Results:  
Not produce an error message, then load the plugin :)

Comment 1

15 years ago
can you post Talkback ID for this crash "mozilla/bin/components/talkback.exe" ?
related: bug 182299.
Severity: normal → critical
Keywords: crash, stackwanted

Comment 2

15 years ago
crashed Firebird 20030506 on Win2k + Flash 6.0r79 and Viewpoint MetaStream 3
Plugin r4 (installer was called VMPMinimalInstall_3_0_12_9.exe): TB20803754Z.
Whiteboard: TB20803754Z

Comment 3

15 years ago
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604
TB20807421G
MetaStream 3 Plugin r4 (VMPMinimalInstall_3_0_12_9.exe)

Worked in IE6.

Comment 4

15 years ago
anyone still crashing ? Please post new Talkback ID if so.

both sites worked for me using build 2003080504 on Win2k + MetaStream 3 Plugin
r4 (VMPMinimalInstall_3_0_12_9.exe)

Comment 5

15 years ago
I get a crash with VMPMinimalInstall_3_0_15_12.exe on all viewpoint sites using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 

ie. 
http://scion.com/drive/360_views/drive_xa_360.html 
http://www.samsungusa.com/viewpoint/dlp/popup.html

Comment 6

15 years ago
With 2004-03-22 debug SeaMonkey build on winXP at
http://www.foxmangames.com/phoenix.html

ffff052f()
NPVIEWPOINT_03000F10! 13401a98()
USER32! 77d43a50()
USER32! 77d43b1f()
USER32! 77d43d79()
USER32! 77d43ddf()
nsAppShellService::Run(nsAppShellService * const 0x00a6e1b0) line 524
main1(int 1, char * * 0x002a2c48, nsISupports * 0x009bf920) line 1298 + 32 bytes
main(int 1, char * * 0x002a2c48) line 1709 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e814c7()

Updated

15 years ago
Keywords: stackwanted
Summary: While trying to load the Viewpoint plugin, the browser crashes. → While trying to load the Viewpoint plugin, the browser crashes [@ NPVIEWPOINT ]
Whiteboard: TB20803754Z → viewpoint crash

Comment 7

14 years ago
talkback says the same thing. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

14 years ago
*** Bug 232764 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
*** Bug 233988 has been marked as a duplicate of this bug. ***
This looks like a plugin bug because the plugin itself crashes

Comment 11

14 years ago
if only we could get traction on bug 156493 :(

Comment 12

14 years ago
*** Bug 245252 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
*** Bug 245724 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Still crashes in Firefox 1.0 @ http://nintendods.com/3d_model/content.html

Comment 15

14 years ago
Some Talkback info:
-------------------
TB2102335K
TB2102270H
TB2096549X
TB2096521W

Comment 16

14 years ago
we need someone from viewpoint to look into this.
Assignee: peterlubczynski-bugs → aberger

Comment 17

14 years ago
Will try to look into this in the near future.  The current assignee of the 
bug (Ari Berger) is no longer at Viewpoint, so feel free to assign it to me.

Updated

14 years ago
Assignee: aberger → mgentry
QA Contact: bmartin → core.plugins
*** Bug 275002 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
Talkback info: TB2698878H

Comment 20

13 years ago
*** Bug 150922 has been marked as a duplicate of this bug. ***

Comment 21

13 years ago
Crashed at
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_DisplayProductInformation-Start?CategoryName=xbr_tube&Dept=tv&ProductSKU=KD34XBR960

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+

Talkback Incident ID: 5443309
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=5443309

Stack Trace:
  	
0xffff05cb
npViewpoint.dll + 0x1a98 (0x13401a98)
USER32.dll + 0x8734 (0x77cf8734)
USER32.dll + 0x8816 (0x77cf8816)
USER32.dll + 0xb4c0 (0x77cfb4c0)
USER32.dll + 0xb50c (0x77cfb50c)
ntdll.dll + 0xeae3 (0x7c94eae3)
SceneComponent.dll + 0x469a3 (0x160469a3)
SceneComponent.dll + 0xb69d (0x1600b69d)
SceneComponent.dll + 0x2a4e4 (0x1602a4e4)
SceneComponent.dll + 0xb6f2 (0x1600b6f2)
npViewpoint.dll + 0x19c7 (0x134019c7)
USER32.dll + 0x8734 (0x77cf8734)
USER32.dll + 0x8816 (0x77cf8816)
USER32.dll + 0x89cd (0x77cf89cd)
USER32.dll + 0x8a10 (0x77cf8a10)
firefox.exe + 0x10ed5d (0x0050ed5d)
firefox.exe + 0x3dae64 (0x007dae64)
firefox.exe + 0x1012 (0x00401012)
kernel32.dll + 0x16d4f (0x7c816d4f)

Comment 22

13 years ago
The plugin is found in C:\Program Files\Viewpoint\Viewpoint Media Player

npViewpoint.dll version: 3.0.15.12
SceneComponent.dll version: 3.0.15.12

Comment 23

13 years ago
Then I updated Viewpoint Media Player at
http://www.viewpoint.com/pub/technology/vmp.html with Internet Explorer (Firefox
crashes, and even after updated, Viewpoint doesn't offer a plugin for Firefox
anyway as it can't recognize Firefox at the download page) and
SceneComponent.dll was updated to 3.0.15.17 (it's downloaded in "NewComponents"
folder then moved when first loaded to "Components" folder under C:\Program
Files\Viewpoint\Viewpoint Media Player) but still had a crash at
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_DisplayProductInformation-Start?CategoryName=xbr_tube&Dept=tv&ProductSKU=KD34XBR960
when I clicked the area drawn by the plugin and rotated a 3D representation of a TV.

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=5443758
Incident ID: 5443758

Stack Trace :
0xffff0191
npViewpoint_03000F10.dll + 0x1a98 (0x13401a98)
USER32.dll + 0x8734 (0x77cf8734)
USER32.dll + 0x8816 (0x77cf8816)
USER32.dll + 0xb4c0 (0x77cfb4c0)
USER32.dll + 0xb50c (0x77cfb50c)
ntdll.dll + 0xeae3 (0x7c94eae3)
SceneComponent.dll + 0x46a44 (0x16046a44)
SceneComponent.dll + 0xb6de (0x1600b6de)
SceneComponent.dll + 0x2a588 (0x1602a588)
SceneComponent.dll + 0xb733 (0x1600b733)
npViewpoint_03000F10.dll + 0x19c7 (0x134019c7)
USER32.dll + 0x8734 (0x77cf8734)
USER32.dll + 0x8816 (0x77cf8816)
USER32.dll + 0x89cd (0x77cf89cd)
USER32.dll + 0x8a10 (0x77cf8a10)
firefox.exe + 0x10ed5d (0x0050ed5d)
firefox.exe + 0x3dae64 (0x007dae64)
firefox.exe + 0x1012 (0x00401012)
kernel32.dll + 0x16d4f (0x7c816d4f)

Comment 24

13 years ago
*** Bug 293184 has been marked as a duplicate of this bug. ***

Comment 25

13 years ago
*** Bug 267886 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking1.8b4?

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-
(In reply to comment #17)
> Will try to look into this in the near future.  The current assignee of the 
> bug (Ari Berger) is no longer at Viewpoint, so feel free to assign it to me.

"Near future" at over a year?  Does Viewpoint still have interest in Mozilla at
this point?  I emailed Viewpoint privately too, and received no response.
*** Bug 305951 has been marked as a duplicate of this bug. ***
Alias: viewpoint

Comment 28

13 years ago
I filed a bug report on nytimes.com suggesting that they encourage Viewpoint to
fix this bug, and that they stop using the Viewpoint plug-in until this problem
is fixed.

Updated

13 years ago
Assignee: mgentry → bdoherty
(Assignee)

Comment 29

13 years ago
There was a bug that caused a crash in Firefox when interacting with a 
Viewpoint media player scene. It is fixed in the latest build of the VMP 
(Viewpoint Media player) available at 
https://components.viewpoint.com/MTSInstallers/archive/3_3_0_29/VMPFullInstall_
3_3_0_29.exe
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Better late than never, I say!  

Verified FIXED using build 2005-09-15-04 on Windows XP SeaMonkey trunk with
various Viewpoint-enabled sites.
Status: RESOLVED → VERIFIED

Comment 31

11 years ago
NOT FIXED on Vista.

Comment 32

11 years ago
duane.wills@gmail.com: please file a new bug, assign it to bdoherty@viewpoint.com and include a talkback incident id (and the version of your plug-in)
Crash Signature: [@ NPVIEWPOINT ]
You need to log in before you can comment on or make changes to this bug.