system crashed - mail & accounts apparently OK, but cannot re-connect to them

RESOLVED WORKSFORME

Status

MailNews Core
Database
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Nigel MacLeod, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4) Gecko/20030529

PC runs OS/2 & crashed whilst running Virtual PC with W2K - Mozilla was NOT
running. On re-boot, htere was a brief message about a Mozilla file, too fast to
read. Now I cannot connect to the email profiles folder, which is separate from
the several versions of Mozilla on the machine - now using 1.4 RC1. I cannot
access the email (2 accounts) and the folders appear to have old dates if I read
the Inbox file. Effectively, I have lost all email. I tried set "mozprofiles" to
point to a backup copy, but got the same result - prompted to create a new
account and cannot access the data.


Reproducible: Always

Steps to Reproduce:
1. Cannot - caused by a system crash which apparently damaged a Mozilla file.
2.
3.

Actual Results:  
No connection to existing mail accounts, either with the current set or a backup.

Expected Results:  
Continue as normal. There have been previous system crashes without this
problem. This was apparently by a damaged Mozilla file.

PC running eCS version 1.02. Mozilla on a JFS drive.
OS: other → OS/2

Comment 1

15 years ago
Sounds like CHKDSK deleted a Mozilla file. Not much we can do.
(Assignee)

Comment 2

15 years ago
do you have quick launch configured? If so, Mozilla might have been running,
unless you hadn't started it during the current session, or you exited from
quick launch (assuming the OS/2 version enables Quick Launch - I don't know if
it does or not). Anyway, if the mail folders are still there, you can get access
to them. Are these pop3 mail accounts? Is your account information still
correct? You should be able to go into mail&news account settings, select Server
Settings under your pop server, and then set the local mail directory to where
your mail folders are on disk (lower right hand corner of the dialog)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Are you still seeing this?
(Reporter)

Comment 4

15 years ago
It was a one-off crash. I was obliged to start my email from scratch. Although
the previous folders are apparently intact, I cannot get Mozilla to use them, so
the contents can only be read by using an editor. 
May I suggest that Mozilla needs an internal backup system to save email, plus
the obvious restore facility.
(Assignee)

Comment 5

15 years ago
Did you try setting the local mail directory account setting for your pop3
server in your new profile to the old local mail directory?
(Reporter)

Comment 6

15 years ago
Yes - but Mozilla apparently ignored them and wanted a new mail account.
(Assignee)

Comment 7

15 years ago
Just to be clear, you went into the account server settings for your pop3
server, and changed the local mail directory? So, in your prefs.js, there should
be an entry for your pop3 server account that points to the old profile
directory where your old mail folders are and not the new profile directory:

user_pref("mail.server.server11.directory", "C:\\Documents and
Settings\\username\\Application
Data\\Mozilla\\Profiles\\profilename\\xxxxxxx.slt\\Mail\\mail.server.com");

And it ignored that directory setting? That would be surprising...

Comment 8

14 years ago
Any more info on this? I think we should just close this bug since it was a one
off crash...

Comment 9

14 years ago
This is a one off crash. I don't know what else we can do with this.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.