If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IDN doesn't work for css and view-source

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: zwnj, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030530
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030530

I wanted to see http://بهنام.esfahbod.info/ but its CSS doesn't load.

And also i want to see view-source:http://بهنام.esfahbod.info/ and it maked
error: "could not be found. Pleases check the name and try again."

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




I have Mozilla 1.4 RPM from RedHat RawHide.
(Reporter)

Updated

15 years ago
Summary: IDA doesn't work for css and view-source → IDN doesn't work for css and view-source

Comment 1

15 years ago
Worksforme in build 2003060503 on Mac OS X 10.2.6

I can see your CSS (proof - your font-familiy for your BODY is "Nesf2, Tahoma,
Arial, sans-serif)" and I can open view-source on your page (proof - you have 2
DOCTYPE's at the top, the first one commented out).
The view-source part of this bug seems to be a duplicate of bug 201040.
So... what encoding is that URL in?  This page loads in ISO-8859-1, and clicking
on the link just gives an error message, which makes it impossible to test this bug.

Comment 4

14 years ago
I have added a test-case: *.idn.ter.dk is set up DNS- and Apache-wise to reply.

Please visit http://זרו.idn.ter.dk/

1. At first Mozilla requests the host "xn--5cab8c.idn.ter.dk", which is okay.
2. But when you choose "View Source", Mozilla makes a new request for
"%c3%a6%c3%b8%c3%a5.idn.ter.dk" (which is "זרו.idn.ter.dk" after it has been
UTF8-encoded and then URL-encoded).

Screenshot showing both requests is available at:
http://stock.ter.dk/moz1.6/idn_1.png


Not only does it not work for "View Source", but it also results in the dreaded
"reload when viewing source", which does not necessary show the source of the
current page, but the source of the page reloaded (where dynamic content could
have changed).
Peter, that's bug 201040.  The original URL this is filed on is defunct, so
marking worksforme per comment 1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.