Closed Bug 208756 Opened 17 years ago Closed 15 years ago

Zooming should maintain text position, top-line should be invariant

Categories

(Core :: Layout, defect)

Sun
SunOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 64926

People

(Reporter: joshgold, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4a) Gecko/20030416 Phoenix/0.5+
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4a) Gecko/20030416 Phoenix/0.5+

The text position changes disorientingly on zooming in and out.  I've
experimenting a bit to figure out how it works and found that sometimes new text
that wasn't onscreen can even wind up in the window after zooming *in*

My feeling is that the least jarring way to keep one's bearings is to keep
invariant the top line of text (or image, etc.) whether zooming in or out.

Reproducible: Always

Steps to Reproduce:
1.Find a page longer than a screenful
2.scroll a bit and then zoom
3.

Actual Results:  
change in visible region

Expected Results:  
top line stationary, lose some text if zooming out, see more text if zooming in.
I think this is a good idea.  It is annoying to be part way down a page, and
find the bit one was reading is longer in view after zooming.
When Increasing or Decreasing the text size, the page content should remain in
the same relative position in the window.  I usually increase the text size when
reading a long article.  Current behavior requires me to scroll (sometimes alot)
to find where I left off.  Obviously, there is already some attempt at remaining
in the same location in the page (because it does not reset to the 'top' and the
scroll bar remains in it's normal position), but there is no effort in
attempting to anchor a particular point in the expanding text (ideally, the
first completely visible line of text).
This probably applies to all platforms (WinXP):

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Oops... Ignore my last 2 comments, I was talking more about bug 64926
Now that you mention it, I think this bug is (one of the many) duplicates of bug
64926.  Can someone confirm that I'm not missing a difference?


Responding to debate in the other bug, for reading long articles, I would find
it disorienting to anchor by the vertical center.  (There's no landmark there,
and it's likely I haven't read down that far yet.)  I would much prefer that the
top line be used.

*** This bug has been marked as a duplicate of 64926 ***
URL: Any.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.