Allow disabling of the new caret based keyboard navigation scheme

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: xterm, Assigned: aaronlev)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030609
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030609

Allow users to choose whether to use the old keyboard navigation scheme
(pressing the arrows scrolls the page directly) instead of the new "editor like"
system. This new system is extremly confusing. Especially if you forget the
caret at some place in the page and then you try to scroll with the arrows and
it jumps to where the caret is.
I also think this should be off by default.

Reproducible: Always

Steps to Reproduce:
1. Click on somewhere in the page (not an edit box).
2. Scroll with the mouse or scroll bar.
3. Click any arrow key.
Actual Results:  
The focus moved to where the caret was left.

Expected Results:  
The page scrolls as it did in old mozilla versions.

Comment 1

16 years ago
Switching the display of the caret is F7
(Reporter)

Comment 2

16 years ago
Thanks alot. I just found it in the keyboard shortcuts help file.
However, since it just appeared out of nowhere, I couldn't tell how to disable it. 
The reasonable place to look for it was in Prefs->Keyboard Nav. Maybe there
should be a toggle there?
(Assignee)

Comment 3

16 years ago
For one thing, I think the feature should be automatically toggled off when the
app launches. At least that way people wouldn't be stuck forever not finding the
off switch for it.

Comment 4

15 years ago
This bug is worksforme. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.