Setting display style to none on table rows does not render table correctly

VERIFIED DUPLICATE of bug 143397

Status

()

VERIFIED DUPLICATE of bug 143397
16 years ago
16 years ago

People

(Reporter: mark, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

Switching on and off the odd and even rows of a table in Javascript using the
display.style attribute, renders the table ever wider at each switch in
visibility. The script at http://www.jacobsm.com/invistblrows.htm demonstrates
this, and the subsequent loose packing of the table rows. DIVs switched on and
off using this method work fine though!

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.jacobsm.com/invistblrows.htm
2. Click the Even button, then the Odd Button
3. Repeat step 2 over and over again, and the table becomes ever wider
4. Also note that the rows are loosely laid out
Actual Results:  
The table becomes ever wider and the rows are loosely laid out.

Expected Results:  
The table should remain its original width and the table height should be such
that the visible rows neatly fill it with no slack space.

Comment 1

16 years ago
in the URL cited, you're setting the display property of the table rows to
"block"; per the CSS spec, table cells are to be assigned the value "table-cell":

http://www.w3.org/TR/REC-CSS2/tables.html#value-def-table-cell

an example that works per the spec is available at:

http://blue.nutrition.tufts.edu/bugzilla/208888.html

recommend -> INVALID

Comment 2

16 years ago
Agreed. See comment #1 on how this is being used incorrectly, and a possible
alternate solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Reopening.  We should be handling the anonymous table frame construction more
gracefully.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
And marking duplicate of the bug that covers this problem.

*** This bug has been marked as a duplicate of 143397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.