if span tags with floats are nested within a div tag, the div tag is displayed above them with zero height

VERIFIED INVALID

Status

()

Core
Layout: Floats
VERIFIED INVALID
15 years ago
11 years ago

People

(Reporter: Jens Schicke, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030527 Debian/1.3.1-2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030527 Debian/1.3.1-2

The div tag should span all the Text and display an ugly red background, instead
it just crunshes into a zero height line of black border-bottom...

Reproducible: Always

Steps to Reproduce:
<div style='backgound-color: #FF0000; border-bottom: solid black 1px;'>
<span style='float: left;'>LEFT</span>
<span style='float: right;'>RIGHT</span>
</div>
Actual Results:  
The div tag displays incorrectly (the described line of black border-bottom)

Expected Results:  
Displayed LEFT and RIGHT in front of an ugly red background and a small black
line under the text and the space between it...

It works as well with external stylesheets.

Comment 1

15 years ago
This is the correct behaviour according to 
http://www.w3.org/TR/REC-CSS2/visudet.html#q17

resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Verified that floats are taken out of flow per spec.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Duplicate of this bug: 415785
You need to log in before you can comment on or make changes to this bug.