Closed Bug 20894 Opened 20 years ago Closed 11 years ago

Mozilla does not startup with multiple kernel threads

Categories

(SeaMonkey :: Build Config, defect)

DEC
OpenVMS
defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: witkowskif, Unassigned)

References

Details

I tried starting up mozilla M11 on a 2-CPU AlphaServer 2100 running OpenVMS
V7.2-1.  After it seams to load all the files it becomes 100% CPU bound on both
CPUs.  It looks like it is going in and out of hibernation.  The SYSGEN
parameter MULTITHREAD was set to 2.  When I set MULTITHREAD to 1, mozilla
started up and I got a window.
I don't know if this is an OpenVMS specific problem or not. Maybe someone
at Netscape can tell me if Mozilla (UNIX flavor) is running on multi-processor
systems yet?

In the meantime, I suggest you disable multiple kernel threads on the
mozilla-bin image:

$ set command sys$update:threadcp
$ rename mozilla.bin. m.exe
$ threadcp /disable==multiple
$ rename m.exe mozilla-bin.
Mozilla on OpenVMS has not yet been qualified for multi-processor support. This
is on the list of things to do, but for now, its unsupported. Starting with M12,
the Mozilla image will be linked with multi-processor support disabled. This
will allow Mozilla to run (albeit on a single processor) on a multi-processor
system.
Reassigning all of leger's unscreened Browser-General bugs to nobody@mozilla.org
for pre-screening and triage.
Changing Component to Threading...
Component: Browser-General → Threading
Sending over to Build folks to get comments
Assignee: nobody → granrose
Component: Threading → Build Config
QA Contact: nobody → cyeh
I have mozilla running fine on a dual 400 MHz Linux machine
running redhat 6.1.  I think colin should own this bug,
he seems to be the most knowledgable about VMS.
The only thing I know about VMS is restarting stuck printer queues...

reassigning to cls and cc'ing leaf in case they have any input.  otherwise, I 
agree, either colin or a unix threading guru should own this bug.
Assignee: granrose → cls
Target Milestone: M18
Looks like it's unanimous.  Congratulations, Colin. :)
Assignee: cls → colin
Status: NEW → ASSIGNED
mass re-assign of all bugs where i was listed as the qa contact
QA Contact: cyeh → chofmann
This is more than likely some problem in the OpenVMS pthread library. Mozilla 
isn't the only complex program that has problems when run in a multi-cpu 
environment. I've in communication with the pthread team at Compaq, but I don't 
think a solution is going to be immediate. Marking "future".
Target Milestone: M18 → Future
Summary: Mozilla does not startup with multiple kernal threads → Mozilla does not startup with multiple kernel threads
I've been testing with multiple kernel threads enabled on a V7.3-1 system and
haven't run into any problems. Maybe this problem is fixed!
I tried installing Mozilla 1.4 stable on my Pentium 4 2.4GHz with hyper-
threading(simulates 2 cpus) and got the same problem.

Went so far as to reimage my system to a fresh install with only XP.
Anyone been able to compile and start Mozilla on a SMP system? I'm commenting
here so I can avoid filing a possible dupe. Doing "ps aux" quickly after
executing run-mozilla.sh shows 8-10 threads, then they all disappear.

Ever since I switched from a single Duron 800@920 to 2 x Pentium II (Descutes)
350@400, I've never been able to run Mozilla on Linux. I'll take a CPU out
tomorrow and see if it works again. (I've been able to run a really old install
of Firebird though).

CC'ing myself.
I have a 2x400 rh9 system, I will pull/build the trunk and see what I get
later tonight.
Just run TestGtkEmbed. It appears, but the browser frame wasn't created. I'll
enable debug and see what I get
TestGtkEmbed and mozilla work fine for me, I built debug, trunk.
My kernel is 2.4.20-20.9smp, 2x400MHz
Heres more info:

Motherboard: MSI 6210 
CPU's: 2 x PII 350@400
RAM: 320MB unbuffered
Distribution: Debian/unstable
Kernel: 2.6.0-test6 (custom build)

Might be a gcc problem. Haven't 'apt dist-upgraded'ed since I switched froma 
single duron to dual pII. I haven't compiled it yet, so i'll come back later
*** Bug 230043 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Colin,
Are you still working on this ?

Does anyone still has a problem, on any platform ?
Sorry, I haven't been working on the OpenVMS port for several years now.
Assignee: colin → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: chofmann → build-config
Target Milestone: Future → ---
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.