rowSpan attribute set by javascript only effective if table already generated

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
minor
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: David Cameron, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

If you set the rowSpan attribute in a table before all the cells in the affected
rows have been defined, the effect is as though the rowspan were not set. If you
set the rowSpan after all the rows have been generated, there are no problems.

The example page I posted (http://www.itis-now.com/bug.htm) has two tables
defined. The rowSpan of the first table can be changed by clicking on the Change
T1 button.

Clicking on the Generate Bad T2 button generates another table. The table has
exactly the same structure at table T1, except is generated using Javascript.
When the table is first generated the rowSpan attribute of the top left cell is
ignored. If you click on Generate good T2, you'll see a table that is identical
to T1 generated. The only difference between the two tables is where the rowspan
for the top left cell is set. You can also clear the table to start again. I
built this quickly and didn't take the time to make it pretty, so no comments on
the style please.

Reproducible: Always

Steps to Reproduce:
1. Click the Generate bad T2 button
2. Click the Generate good T2 button
3. See the difference
4. View the source
5. Refresh and return to step 1 if necessary

Actual Results:  
The table is incorrectly generated and the rowSpan attribute is ignored.

Expected Results:  
The two butttons should produce an identical result.

Comment 1

14 years ago
Confirmed i firefox0.8 on win2k. Should probably go to layout:tables but I'll
try to collect more information first. Marking NEW. Sending to DOM:HTML
Status: UNCONFIRMED → NEW
Component: DOM → DOM: HTML
Ever confirmed: true
QA Contact: desale → ian

Comment 2

14 years ago
Created attachment 142532 [details]
Testcase for bug 209015

This testcase demonstrates that setting rowSpan on a cell before the next row
is inserted in the tree fails, while setting rowSpan after the new row is
inserted in the tree succeeds. Any ideas anyone? Should we send this to layout?

Comment 3

14 years ago
Same Bug here, happens on Mozilla 1.7b and current nightly build. Does not
happen on Mozilla 1.4 and 1.6. Did not check 1.7a. Tested on Windows only.

I could not reproduce the "workaround" with setting rowspan after the table is
created at first, then noticed the difference:

when inserting child-nodes directly into the TABLE-Node even the workaround
won't help you. When creating a TBODY before (either in html, or inserted via
JavaScript), the workaround will work.


see this sample page: http://www.authmann.de/test_rowspan.html
With the testcase, I can see the bug in Mozilla1.7, but I can't see the bug in
the latest nightly trunk build.
I'm resolving this WFM. 
If anyone can still reproduce in the latest nightly trunk build (
http://ftp.uni-erlangen.de/pub/mozilla.org/firefox/nightly/latest-trunk/ ), then
please reopen.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.