add parameter to openPreferences to specify which pane to open

VERIFIED FIXED

Status

()

Firefox
Preferences
--
enhancement
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Henrik Gemal, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
With Mozilla Firebird you can't specify which panel to show when opening the
preferences.

The openPreferences() function should have some parameter where you could
specify the panel to show.
By design, the preferences panel opens the last window opened.  Adding this
ability (I'm guessing for extension authors?) is an enhancement, not a bug.

--> Blocking 191524.
--> enhancement
--> tweak summary to reflect enhancement

Blocks: 191524
Severity: normal → enhancement
Summary: openPreferences should have parameter → add parameter to openPreferences to specify which pane to open
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 3

13 years ago
Fixed with a checkin for bug 284081 (attachment 180784 [details] [diff] [review]).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Wow, this stayed open while the bug was fixed, rewritten, broken, then fixed
again :).
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.