[PP]Solaris: Crash clicking OK in File Dialog w/ no selection

VERIFIED FIXED in M14

Status

()

Core
XUL
P2
critical
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: mats, Assigned: Stuart Parmenter)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 19-JAN waiting for a stable Solaris build)

(Reporter)

Description

19 years ago
TO REPEAT:
1. start mozilla
2. invoke menu item File->Open File...
3. click OK (in the File Selection dialog that pops up)
4. wait a few secs... boom

BUILD AND PLATFORM BUG FOUND ON:
Mozilla nightly build 1999120509 on Sun/Solaris2.6/sparc

ADDITIONAL BUILDS TESTED:
Bug does NOT occur in mozilla nightly build 1999120516 on Windows NT4.0 sp5.

ADDITIONAL INFO:
Stack trace on Sun/Solaris2.6/sparc follows

t@1 (l@1) terminated by signal BUS (invalid address alignment)
(dbx) where
current thread: t@1
=>[1] Length__C18nsSimpleCharString(0x35af1, 0x93aa1c, 0xee37b840, 0x0, 0x5,
0xef3ffca0), at 0xef413f58
  [2] GetLeaf__C18nsSimpleCharStringc(0xee2f37a0, 0x2f, 0x0, 0x5, 0x81010100,
0xff00), at 0xef4114f4
  [3] GetLeafName__C10nsFileSpec(0xee2f37a0, 0xee37b840, 0x5, 0xef435300, 0x3ac,
0x93ab01), at 0xef4117a8
  [4] Read__22nsDirectoryIndexStreamPcUiPUi(0x93aa00, 0x942800, 0x400,
0xee2f3894, 0x35, 0xee2f37a0), at 0xee35150c
  [5] 0xef41df10(0x93aa00, 0x942800, 0x0, 0x400, 0xee2f3894, 0x0), at 0xef41df0f
  [6]
WriteSegments__Q26nsPipe18nsPipeOutputStreamPFPvPcUiUiPUi_UiPvUiPUi(0x8ebe14,
0xef41def4, 0x93aa00, 0x400, 0xee2f3adc, 0xef41daf8), at 0xef41dc58
  [7] WriteFrom__Q26nsPipe18nsPipeOutputStreamP14nsIInputStreamUiPUi(0x8ebe14,
0x93aa00, 0x400, 0xee2f3adc, 0xef41df20, 0x2000), at 0xef41df5c
  [8] Process__15nsFileTransport(0x92cd00, 0x0, 0x98680, 0xef4081f8, 0x0,
0x56e00), at 0xee347ca0
  [9] Run__15nsFileTransport(0x92cd00, 0xee347978, 0x0, 0x0, 0x0, 0x0), at
0xee347984
  [10] Run__20nsThreadPoolRunnable(0x9a260, 0xef430be4, 0x9a260, 0xee2f3da0,
0xee2f3da0, 0x0), at 0xef430c24
  [11] Main__8nsThreadPv(0x9a280, 0xef42f968, 0x0, 0x0, 0x0, 0x0), at 0xef42f984
  [12] 0xef357d3c(0x50c, 0xee2f3e38, 0x0, 0x0, 0x0, 0x0), at 0xef357d3b
(dbx) quit

Updated

19 years ago
Assignee: trudelle → sdagley
Priority: P3 → P2
Target Milestone: M13

Comment 1

19 years ago
assigning to sdagley as p2 for m13, cc mcafee

Comment 2

19 years ago
*** Bug 20908 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
So who in QA is running a Solaris system so I can look at this problem?

Updated

19 years ago
Summary: [PP] Crash when clicking OK in File Dialog when nothing selected → [PP]Solaris: Crash clicking OK in File Dialog w/ no selection

Comment 4

19 years ago
Crashes on Solaris, doesn't crash on Linux.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Thanks to help from mcafee and pavlov we have a fix for this bug and pav will
check it when the tree opens on 2000-01-07.  Marking bug as fixed although it
won't show up in today's build.  We also don't seem to have anyone in internal QA
running Mozilla under Solaris so verification will have to be external (or
someone can go look at a build on mcafee's Solaris boc)

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 6

19 years ago
nossir. This still crashes on Solaris builds from 20000112.

Updated

19 years ago
Assignee: sdagley → pavlov
Status: REOPENED → NEW

Comment 7

19 years ago
Just talked to pav and am re-assigning the bug to him to check if his changes
from yesterday affected the fix from Friday.

Comment 8

19 years ago
Clearing FIXED resolution due to reopen.
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 9

19 years ago
moving to M14
(Assignee)

Comment 10

19 years ago
Clicking OK without a selection will return the directory you are currently in

as the file name.  I'm not sure this is the desired behavior, but if you really

didn't want it to do anything, you should have hit cancel.  I can't reproduce

this crash.  This appears to be a bug in either the directory listing code or

the filespec code on solaris.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

19 years ago
checked in fix.

Updated

19 years ago
Whiteboard: 19-JAN waiting for a stable Solaris build
Seems to be working now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.