If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Print or print preview crashes Mozilla at http://startlinux.co.nz/articles/article_22.php [@ nsSplittableFrame::Destroy]

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Dom Incollingo, Unassigned)

Tracking

({crash})

Other Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Mozilla crashes at http://startlinux.co.nz/articles/article_22.php if you use
the print or print preview functions.  Using Build Id 2003052912 (1.4 RC1) on Linux.

Steps to reproduce:

1) Navigate to http://startlinux.co.nz/articles/article_22.php
2) Choose File -> Print Preview
3) After the Print Preview window is opened, choose the Close button on the
Print Preview screen.
4) Mozilla crashes.  Please see Incident Id.TB20950882Z.

Alternate steps to reproduce:

1) Navigate to http://startlinux.co.nz/articles/article_22.php
2) Choose File -> Print 
3) Press the Print button on the Print dialog box.
4) The web page is printed successfully, but Mozilla crashes.

Expected results:

Mozilla should not crash.

Updated

15 years ago
Keywords: stackwanted

Comment 1

15 years ago
Can anyone fetch the stack trace from the talkback report, please ?
Created attachment 125463 [details]
Stack from talkback

This is not quite the same stack as in bug 193686, but please test with a
recent build to see if this crash has also been fixed.
(Reporter)

Comment 3

15 years ago
Both the Print and Print Preview functions work correctly using build 2003061108
on Linux.  Will this fix make it into the final version of the 1.4 release?

Comment 4

15 years ago
> Will this fix make it into the final version of the 1.4 release?

bug 193686 is fixed on the branch.  see bug 193686 comment 39

I can't reproduce this with current trunk or 1.4RC1.
Keywords: stackwanted

Comment 5

14 years ago
Hello,

I have the same problem on: http://www.wimb.net/index.php?s=home&page=5

In preview mode the browesr crashes with an error in GKLAYOUT.DLL
Mozille built 2003071508, same problen in Firebird. Not in netscape 7.1, built
20021120

wimb@wimb.net
Summary: Print or print preview crashes Mozilla at http://startlinux.co.nz/articles/article_22.php → Print or print preview crashes Mozilla at http://startlinux.co.nz/articles/article_22.php [@ nsSplittableFrame::Destroy]

Comment 6

14 years ago
I can't reproduce this either. Reporter noted it was working in comment #3.
Resolving worksforme.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsSplittableFrame::Destroy]
You need to log in before you can comment on or make changes to this bug.