Large Websieve table makes Mozilla go brain dead

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: mark, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507

Websieve generated table caused very long rendering time and afterwards, Mozilla
wouldn't load new pages, open windows or quit. Had to kill it manually. As this
page is dynamically generated, I captured it in IE (which has no trouble
rendering) and posted it at the indicated URL. Although this is mediocre HTML,
it seems as though it shouldn't prevent Mozilla from subsequently operating.
Earlier versions of Mozilla seem to render it, but lock up. Latest beta doesn't
seem to finish rendering.

Reproducible: Always

Steps to Reproduce:
1. Load the URL: http://www.taom.com/bugzilla-websieve2.html
2. Try to open windows, link to URLs, quit. 


Actual Results:  
On 1.4b, rendering took forever and left a blank page. Could not subsequently
open any windows or go to any URLs. Could not quit even though the menubar
seemed to be operating.

Expected Results:  
A rendered page would have been nice, but either way Mozilla should not go brain
dead afterwards.

Comment 1

15 years ago
WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla
Firebird/0.6

Comment 2

14 years ago
File not found, can't test.

Comment 3

14 years ago
Reporter could you please attach the testcase to the bug or make the url
otherwise accessible.  Or close the bug if you cant reproduce the problem.

Comment 4

13 years ago
7month no comment no wroking url, Please provide a testcase before reopening the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.