mozilla just crashes, or turns off when trying to open this page. Can't see any core dump though...

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: daniel, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla-1.4 RC 1

I am using the 1.4 version RC 

Just when trying to open the page, it almost makes it then switches off.  I
would say segments out, however I do not see a core dump anywhere and I have
looked in the usual places..



Reproducible: Always

Steps to Reproduce:
1.go to link
2.nothing else is needed.
3.I have the mozilla mail open as well....

Actual Results:  
crashes

Expected Results:  
open page just like anyother news or web page.

Comment 1

16 years ago
the site uses java, is your java installed correctly?
you can check at this german link: http://www.heise.de/ct/browsercheck/java.shtml
you should see: Java ist AKTIV!   and a coloured cube below, which can be turned
with using the mouse, if you left-click on it.

wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030611
(Reporter)

Comment 2

16 years ago
my java plugins are active however when I clicked on the site you gave mozilla
turned off.  

My 1.1-0 versions which I installed as rpms worked fine.

Will keep on trying though, if you have any other ideas or fixes, I will be
happy to know and try..

Comment 3

16 years ago
in edit - preferences - advanced
uncheck the box for ENABLE JAVA.

then visit the page again : if Moz doesn't crash this time it is definitely your
Java install that brings it down. Possibly Moz DOES show you JAVA installed
under about:plugins but possibly the privileges are wrong.

See http://plugindoc.mozdev.org/linux.html#Java how to fix your Java prob.

If that solves your problem then this bug should be marked to component OJI with
status whiteboard DUPEME added.

Please report back if your problem is solved, otherwise this bug will be marked
as resolved.

Comment 4

16 years ago
make sure you have a symlink in your plugins/ directory.
Severity: normal → critical
Component: Browser-General → OJI
Keywords: crash
(Reporter)

Comment 5

16 years ago
I have the sym links, still shuts down.  Look if these pages work for you guys
then there must be something wrong my side, in which case sorry.

I will keep bashing away at it. :-)

Comment 6

16 years ago
do you have .fon files in your font path ? does removing the Microsoft .fon file
fix the crash ?
Component: OJI → Browser-General
(Reporter)

Comment 7

16 years ago
no .fon in font path..
(Reporter)

Comment 8

16 years ago
I ran mozilla from the terminal window, and got these messages.  

To repeat this I clicked on "Tools ->Web devel->Java Console" and again mozilla
exited.





LoadPlugin: failed to initialize shared library
/home/daniel/.mozilla/plugins/libcult3dplugin.so
[/home/daniel/.mozilla/plugins/libcult3dplugin.so: undefined symbol: good__C3ios]
LoadPlugin: failed to initialize shared library
/usr/local/mozilla/plugins/libcult3dplugin.so
[/usr/local/mozilla/plugins/libcult3dplugin.so: undefined symbol: good__C3ios]
The font "-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1" does
not support all the required character sets for the current locale "en_US.iso885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")
The font "-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1" does
not support all the required character sets for the current locale "en_US.iso885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")
The font "-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1" does
not support all the required character sets for the current locale "en_US.iso885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable
(Reporter)

Comment 9

16 years ago
http://mozilla.org/quality/ngdriver/suites/javascript/img002.html

I ran this test, and it said that a bug report is required.  I am guessing that
is it all connected.

Comment 10

16 years ago
Daniel, can you do the following:
 - remove your cult plug-in file ? It's not supported, see
http://plugindoc.mozdev.org/linux.html#Cult3D
 - remove any Java softlink from your plugins/ directory,
 - report if it works fine (i.e. not crashing).
Then, add the Java softlink back (mention here how it looks like 'ls -la
plugins/') and see if you still crash.
(Reporter)

Comment 11

16 years ago
phew.. that solved it. 

http://plugindoc.mozdev.org/javalinux.html

I followed the sym link instructions. I also did a complete reinstallation and
purged my system of anything mozilla ;-)

cool.  Thanx all
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.