Startup hangs with libgdk-1.2 from Solaris 8 SFWgtk package

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Bernd Nies, Unassigned)

Tracking

({stackwanted})

Trunk
Sun
Solaris
stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030313

Sun offers two different Packages that contain the glib and gtk libraries:

a) The ones that come with Netscape 7 are: SUNWGlib SUNWGtkr SUNWGtku SUNWgcmn.
They are installed in /usr/sfw.

b) The ones that come with the Solaris 8 Software Companion CD are: SFWglib
SFWgtk SFWgtken. They are installed in /opt/sfw.

While Netscape7 and Mozilla 1.4a work fine with the libgdk-1.2 library from a)
they both don't start up and hang with empty window with the library from b).
Although the libraries have the same version the files are different in file
size. Example:

-rwxr-xr-x   1 root     bin      2718276 Nov 28  2001
/opt/sfw/lib/libgtk-1.2.so.0.9.1
-rwxr-xr-x   1 root     bin      1356116 Mar  9  2002
/usr/sfw/lib/libgtk-1.2.so.0.9.1

-rwxr-xr-x   1 root     bin       848748 Nov 28  2001
/opt/sfw/lib/libglib-1.2.so.0.0.10
-rwxr-xr-x   1 root     bin       262076 Mar  8  2002
/usr/sfw/lib/libglib-1.2.so.0.0.10

-rwxr-xr-x   1 root     bin        39668 Nov 28  2001
/opt/sfw/lib/libgmodule-1.2.so.0.0.10
-rwxr-xr-x   1 root     bin        11940 Mar  8  2002
/usr/sfw/lib/libgmodule-1.2.so.0.0.10

Probably more a Sun inconsistency and shared library woe than a Mozilla bug, but
did not find an appropriate bug in Bugzilla I wanted to report this because it
caused headache ...

BTW: The startup script 'mozilla' works only if you start it from the
installation directory. You need to ad a 'cd $dist_bin' at the end before the exec.

Reproducible: Always

Steps to Reproduce:
1. Remove SUNWGlib SUNWGtkr SUNWGtku SUNWgcmn packages
2. Install SFWglib SFWgtk SFWgtken
3. Set LD_LIBRARY_PATH in the startup script
4. Launch Mozilla/Netscape

Actual Results:  
Browser hangs with empty window after startup.

Expected Results:  
Browsing happily.

uname -a
SunOS vantage 5.8 Generic_108528-18 sun4u sparc SUNW,Ultra-5_10

Solaris Packages:

system      SFWglib         GLIB - Library of useful routines for C programming
system      SFWgtk          GTK - The GIMP Toolkit
system      SFWgtken        GTK - Theme Engines
system      SFWgcmn         gcmn - Common GNU package
system      SUNWGlib        GLIB - Library of useful routines for C programming
system      SUNWGtkr        GTK - The GIMP Toolkit (Root)
system      SUNWGtku        GTK - The GIMP Toolkit (Usr)
system      SUNWgcmn        gcmn - Common GNU package
OS: SunOS → Solaris

Comment 1

15 years ago
Reporter:
1. We need a stack trace from the hung mozilla.
2. Is it possible that the GDK/GTK+ libs are compiled with gcc ?
Keywords: stackwanted
(Reporter)

Comment 2

15 years ago
Don't know whether those libraries are compiled with GCC or the Sun Compiler.
Maybe it's somewhere in the package documentation. How do I get a stack trace?

Comment 3

15 years ago
Bernd Nies wrote:
> How do I get a stack trace?

Three ways:
1. Using /usr/proc/bin/pstack on Solaris >= 2.8:
% /usr/proc/bin/pstack PID
  or
% /usr/proc/bin/pstack core-file-name
2. Using dbx (if installed):
Start Mozilla like this
% ./mozilla -g -d dbx
# type CTRL-C when you think it hangs and type "where" to get a stack trace
3. Using gdb (if installed, expect that it may consume a few hundred megabytes):
Start Mozilla like this:
% ./mozilla -g -d gdb
# type CTRL-C when you think it hangs and type "where" to get a stack trace
(Reporter)

Comment 4

15 years ago
Created attachment 125728 [details]
Pstack of hung mozilla 1.4a with libgdk-1.2.so.0.9.1 from Sun SFWgtk package

Output after startup:
Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.

There's no information on the CD whether the libraries were build with GNU
compiler or Sun compiler.
(Reporter)

Comment 5

15 years ago
Mozilla 1.4rc1 does work with the libraries from SFWgtk.

Comment 6

15 years ago
Marking WFM as per reporter comments. Please reopen if I misunderstood your
comment 5 and still having this issue with 1.4 final.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.