close sidebar tab on click of open sidebar tab

RESOLVED DUPLICATE of bug 34925

Status

SeaMonkey
Sidebar
--
enhancement
RESOLVED DUPLICATE of bug 34925
15 years ago
13 years ago

People

(Reporter: Peter Tandler, Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

If a sidebar tab is opened, it should be possible to close it again by clicking
again at the title. (Just as the "explorer" tabs in StarOffice worked.)

Reproducible: Always

Steps to Reproduce:
1. Click on the "bookmarks" sidebar tab
2. Click again on the "bookmarks" sidebar tab

Actual Results:  
The "bookmark" sidebar tab is still open

Expected Results:  
The "bookmark" sidebar tab is closed again, and the one below is opened instead.

This is another idea to solve the problem of long mouse travel times when
switching to another tab (see Bug 132068).

Comment 1

15 years ago
This is not a bug. The sidebar is designed to always keep at least one sidebar
tab open, so that it fills the entire space of the sidebar. Since this is the
expected behavior, it is not a bug.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

15 years ago
Ok, maybe my description was not precise enough ... what about this one:

If a sidebar tab is opened, it should be possible to close it by clicking
again at the title, as long as it is not the last (lowest) tab. When the tab is
closed the one below must be opened instead.

This allows to easily switch between tabs using the mouse -- without having to
move the mouse between the top and bottom of the sidebar.

... better to understand?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

15 years ago
Yes, that sounds reasonable. However, since this intended behavior, and not a
bug, I've changed the Severity to "enhancment".

Confirming.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: close sidebar tab if clicked on title if tab is open → close sidebar tab on click of open sidebar tab

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 34925 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.