Crash on close with data loss (bookmarks)

VERIFIED DUPLICATE of bug 193567

Status

()

Firefox
Bookmarks & History
--
critical
VERIFIED DUPLICATE of bug 193567
15 years ago
12 years ago

People

(Reporter: Roman R., Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I had been using Firebird for  several days without restarting it. It has
survived several hibernations and waking up of my system (WinXP). Memory
consumption of Firebird has risen to 167 MB, even though I only had one tab open
at times (at other times, it was perhaps, about 20). Yesterday, I decided to
close the program to deallocate the memory it had been hoarding. So I saved all
open tabs in bookmarks for later use and initiated the close operation. It asked
me if I wanted to close all open tabs, to which I agreed. Then my whole system
hung. I could see changes in CPU status by the task manager (which indicated
that the system was not dead), but the system wouldn't respond to any of my
commands (via keyboard or mouse, not even CTRL+ALT+DEL). So, I had to reboot my
computer. After it came back on, I launched Firebird and found all my bookmarks
gone, including those that I had saved many days ago during different sessions,
and which had definitely been saved in the bookmark file. The bookmark file
occupies 21,526 bytes and contains only a bunch of empty lines. There were gone
fruits of multi-hour labor.

This is the worst data loss I have ever had with any software. Oh… no… Netscape
4.x has lost my mail during a move operation, which I guess is worse than losing
bookmarks. Perhaps, somebody who's competent in fault tolerance needs to take a
look at how things are done with this software.


Reproducible: Didn't try

Steps to Reproduce:
-> Phoenix
Assignee: general → chanial
Component: Browser-General → Bookmarks
Product: Browser → Phoenix
QA Contact: general → asa
Version: Trunk → unspecified

Comment 2

15 years ago
Roman, just a few questions before I try to reproduce this over weekend on one
of our XP boxes:

- was this a new installation into a _new_ directory or did you override an
already existing installation?

- if this was not the first installation on your box: did you create a _new_
profile or did you re-used a previous one?

- since you mentioned a check, whether you want to close all open tabs: do you
have any additional extensions installed? If so, which one?

Finally I want to point out that this is a pre 1.0 version of a software
product! And despite the fact the MozillaFirebird is in an already stable status
(compared to many other post 1.0 products) one should not forget that this is
still beta software - and if one decides to use beta software one has also to
take care about the possible risks, e.g. by making backups of at least the
bookmarks.html since this is the most valuable file for most of us :)
(Reporter)

Comment 3

15 years ago
- I had (and still have) phoenix (04-26-03) in its own directory and installed
MozillaFirebird-0.6 in a seperate directory.

- I reused a previous profile. And I don't think I've launched Phoenix after
installing MozillaFirebird-0.6

- Extensions I have:
1) mozilla google toolbar (0.5.0.07 -- according to its settings dialog box);
2) User Agent Switcher (v. 0.1);
3) Nuke Image 0.3;
4) Tabbrowser Extensions. Unfortunately, I just upgraded TBE, and, therefore,
cannot tell you which version I had when I had the crash.

You are correct about having to make backups. I didn't think about it because
I'd never lost bookmarks before. I thought that losing latest entries was
possible but not the whole file. Is there a fragment of code that deletes the
file in case of an error? Oh... the file isn't lost; it contains lots of empty
lines, which tells me that the error occured during writing to the file.
Perhaps, a backup copy needs to be created before updating the original?

Comment 4

15 years ago
Well, concerning the backup issue there already exists a bug filed against
SeaMonkey (bug #193567). Concerning that profile-thing I'd kindly ask you to
follow the suggestions made in the release notes for Mozilla Firebird 0.6:

>Download, Install and Uninstall
>PLEASE NOTE: You should create a new profile for Mozilla Firebird 0.6 ... 

So with all that extensions installed on your side I doubt I will face this
problem on Monday since I can only try to reproduce this with latest nightly
together with a fresh profile...
Besides the extensions and the lack of a talkback ID, it sounds like XP was
rebooted via a reset button or power switch (since keyboard/mouse was
unresponsive it certainly wouldn't have been a graceful shutdown).  That being
the case, if the file was being written when interrupted it would have likely
been corrupted the way you described.  

Since the last real statement in the bug report is concerning fault tolerance,
I'm going to mark this as a duplicate against 193567 since a fault tolerance
system would have been needed to prevent the dataloss.

*** This bug has been marked as a duplicate of 193567 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
mass verification of dupes
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.