Last Comment Bug 209217 - Portions of markup do not render (invisible) after cookie set for alternate style sheet.
: Portions of markup do not render (invisible) after cookie set for alternate s...
Status: RESOLVED FIXED
[altss]DUPEME?
:
Product: Core
Classification: Components
Component: Layout: R & A Pos (show other bugs)
: Trunk
: x86 All
: -- normal with 1 vote (vote)
: ---
Assigned To: layout.r-and-a-pos
: Hixie (not reading bugmail)
:
Mentors:
http://www.zeldman.com/
Depends on: 193069
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 13:43 PDT by Matthew Schlosser
Modified: 2003-10-02 15:47 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screen grab of zeldman.com showing bug behavior, Mozilla 1.4 RC1 Windows XP Pro SP1 (85.02 KB, image/png)
2003-06-16 11:47 PDT, Mike Marco
no flags Details

Description Matthew Schlosser 2003-06-12 13:43:35 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: O&ShyPgJMozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When visiting the page in question, layout is fine.  If you switch to the
green/white alternate style sheet, click the menu bar and press enter to revisit
the page (not reload), the menu at left will not render.  If you reload the
page, it will render.  This is not a CSS coding issue.

The style sheet selector uses javascript to switch your stylesheet, then sets a
cooking with your preferred sheet.

Have a nice day ;)

Reproducible: Always

Steps to Reproduce:
1. Visit the default page (www.zeldman.com)
2. On the left, note the style sheet switcher.
3. Select style 3 (green + white)
4. Re-visit the page (do not reload the page)
5. You will see quite obviously what the issue is.
6. Reload the page to work around.

Actual Results:  
The navigation bar on the left does not render.

Expected Results:  
Mozilla should have displayed the page as it looks after the style switch or
after hitting reload.

Default theme, occured both before and after installing All-In-One Gestures
extention.  The extention does not seem to be at fault.
Comment 1 Andrew Schultz 2003-06-12 21:58:25 PDT
> 2. On the left, note the style sheet switcher.

the "abc" blocks...

> 3. Select style 3 (green + white)

with linux trunk 20030612 and firebird 0.6, the style switched immeadiately and
without incident.

> 4. Re-visit the page (do not reload the page)

still looked ok.
Comment 2 Jeff Bender 2003-06-13 07:06:25 PDT
I was able to reproduce this bug on Windows XP, SP1.  This might not be the case
in the Firebird Linux Distro.
Comment 3 Matthew Schlosser 2003-06-13 07:13:37 PDT
Allow me to clarify:

1. Visit the default page (www.zeldman.com)
2. On the left, note the style sheet switcher (abc, abc, abc...).
3. Select style 3 (green + white)
4. Re-visit the page (do not reload the page).  Do this by clicking the location
bar and pressing enter/return.
5. The menu bar at left will not render when the page is loaded.
6. Reload the page to work around.
Comment 4 Chris Neale 2003-06-16 09:21:51 PDT
seen this myself in cvs builds of Firebird from the trunk, Linux
Comment 5 Bill Mason 2003-06-16 09:39:30 PDT
Confirming new based on previous comments.
OS->All based on comment 4

I've also seen this in Firebird 20030614 PC/WinXP but couldn't always reproduce.
 I don't even use the style switcher on that site.
Comment 6 Mike Goodspeed 2003-06-16 10:11:36 PDT
I can verify this on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030616 Mozilla Firebird/0.6 and Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.4b) Gecko/20030602 Mozilla Firebird/0.6.

The div in question seems to be id="secondarynav".  I'll see if I can find a
smaller testcase.
Comment 7 Mike Marco 2003-06-16 11:47:07 PDT
Created attachment 125763 [details]
Screen grab of zeldman.com showing bug behavior, Mozilla 1.4 RC1 Windows XP Pro SP1
Comment 8 Ben Darlow 2003-06-16 12:09:27 PDT
I had encountered styleswitcher quirks using (I believe) the same script (or a
variation thereof) at http://kapowaz.diaryland.com/ which I think exhibits
similar problems; in particular the height of elements containing background
images doesn't change until the page is reloaded.
Comment 9 Mike Goodspeed 2003-06-16 15:57:30 PDT
It might be related a bug I reported: bug 209217, in which some div's take the
wrong values when upon a stilesheet change.  This doesn't quite seem the same,
as it doesn't happen constantly, and requires you to revisit the page, etc.
Comment 10 Mike Goodspeed 2003-06-16 15:59:43 PDT
er, bug 207716... sorry.
Comment 11 Christopher Hoess (gone) 2003-06-17 23:47:07 PDT
Transferring to positioning. I think your assessment may be correct, Mike; the
<div> is absolutely positioned, DOM Inspector shows it with the correct computed
styles, but once it breaks it takes an initial reflow to trigger the proper display.
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2003-06-18 00:05:44 PDT
This may well get fixed by bug 193069 (some of the fun-n-games in bug 193014 may
be involved).
Comment 13 Boris Zbarsky [:bz] (still a bit busy) 2003-10-02 15:47:33 PDT
Fixed by patch in bug 200931

Note You need to log in before you can comment on or make changes to this bug.