Doen't work "Automatic proxy configuration URL" in Options/Connections

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: g.bellucci, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.79 [en] (Win98; U)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

It's simple. It doesn't work with my Automatic proxy connection that i
use with Netscape, IE explorer and Mozilla 1.3.
"Automatic configuration" let me visit only page of my 
net regione.toscana.it, but it doesn't let me see over my
net and can't use proxy.
Manual configuration works!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
It can't connect, it say:
the connections was refused when attepting to contact wwws.foo.it


This is the script used:

function FindProxyForURL(url,host)
{

if(localHostOrDomainIs(host, "www.consiglio.regione.toscana.it"))
   return "PROXY 159.213.32.228:8080";

if (dnsDomainIs(host, ".regione.toscana.it") ||
    isInNet(host, "127.0.0.1", "255.255.255.255")
   )
	 return "DIRECT";
 
if(dnsDomainIs(host, "www.rete.toscana.it") ||
   dnsDomainIs(host, "www.turismo.toscana.it") || 
   dnsDomainIs(host, "sil.rete.toscana.it") || 
   dnsDomainIs(host, "web.rete.toscana.it") || 
   dnsDomainIs(host, "www.cultura.toscana.it") || 
   dnsDomainIs(host, "www.sanita.toscana.it") ||
   dnsDomainIs(host, "www.firenze.turismo.toscana.it") || 
   dnsDomainIs(host, "www.giubileo.toscana.it") || 
   dnsDomainIs(host, "www.agriturismo.toscana.it") || 
   dnsDomainIs(host, "www.protezionecivile.regione.toscana.it") || 
   dnsDomainIs(host, "www.filmcommission.toscana.it") ||
   dnsDomainIs(host, "www.e.toscana.it") ||
   dnsDomainIs(host, "www.rtrt.toscana.it") ||
   dnsDomainIs(host, "monitor.rete.toscana.it") ||
   dnsDomainIs(host, "anagrafe.rete.toscana.it") ||
   dnsDomainIs(host, "anagrafesvil.rete.toscana.it") ||
   dnsDomainIs(host, "monitornal.rete.toscana.it") ||
   dnsDomainIs(host, "forum.rete.toscana.it") ||
   dnsDomainIs(host, "nwebaccess.regione.toscana.it") ||
   dnsDomainIs(host, "videoconferenza.regione.toscana.it") ||
   dnsDomainIs(host, "www.lavoroesalute.it") 
  ) 
  return "DIRECT";
else
  return "PROXY 159.213.32.228:8080";

}

Comment 1

15 years ago
My situation may be similar so I'll comment vs adding a new bug.

When using automatic proxy configuration and your click a URL from a program
(Outlook, Word, etc) and Firebird is launched (vs already being open), the
connection is tried before the "proxy.pac" is read.  You can confirm this with a
netstat command showing an direct connection attempt.

If Firebird is already open when a link is clicked, the "proxy.pac" directives
are respected and the page opens as desired.

This is always reproducable.
My proxy.pac file is similar to the one posted here.
I have tested it with the latetst build (07/07/03 - Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.5a) Gecko/20030706 Mozilla Firebird/0.6)

Comment 2

15 years ago
There#s a meta bug filed against SeaMonkey: bug #79893 listing several PAC
problems in SeaMonkey => Giacomo, Pat - are your problems really Moz.Firebird
specific or do you see the same problems also using latest SeaMonkey? Comparison
to Mozilla 1.3 doesn't help much since a lot of stuff changed since 1.3...

Comment 3

15 years ago
Hi Erik.
My problem is Firebird specific.  I've never looked at SeaMonkey.
I'd be happy to test/try/confirm other programs if that would help.

Thanks

Pat
Giacomo, Pat, "SeaMonkey" is the core Mozilla Suite.

The latest builds can always be found at
http://ftp.mozilla.org/pub/mozilla/nightly/latest Both of you probably just want
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe

Make sure you install to a different directory than any existing mozilla
installation.

If the problem exists there, as I expect it will if it exists on current
Firebird builds, then this belongs to the Browser-HTTP Networking component.
In the absence of further information from Pat or Giacomo, I'm going to mark
this WORKSFORME until further information is provided in the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.