If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Absolute URI stylesheets not loaded.

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Luke Ross, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

If the <?xml-stylesheet tag's href contains an absolute URI, the stylesheet will
not be loaded and the text of the XML displayed as though no stylesheet is present.

Reproducible: Always

Steps to Reproduce:
1. Create an XSL stylesheet and XML instance
2. Insert PI of form <?xml-stylesheet type="text/xsl"
href="http://absolute/path/to/stylesheet.xml" ?>
3. Open the XML document in Mozilla.

Actual Results:  
The text of the XML is shown on screen.

Expected Results:  
The stylesheet be loaded, and the XML document processed against the stylesheet.

This appears to be a regression, as absolute URIs worked under Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.3b) Gecko/20030211.
note that XSLT-stylesheets are only allowed to be loaded from the same server
(although it should of course not matter weather you use an absolute or relative
url to it). Is that what is happening? If not, please provide a testcase
(Reporter)

Comment 2

15 years ago
After some checking, we worked out that this was because of the stylesheet
accessing the same host through a hostname alias, so Mozilla deemed it to be a
different host and so didn't load the stylesheey.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
cool
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.