IMAP + CRAM-MD5 auth fails but no way to disable it

RESOLVED DUPLICATE of bug 208026

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED DUPLICATE of bug 208026
15 years ago
10 years ago

People

(Reporter: alor, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) 

i'm using an IMAP server which does not support CRAM-MD5 auth. mozilla tries to
use it and the authentication process fails. even if I disable the auth via
mail.server.default.auth_login = false, mozilla continues to authenticate via
CRAM-MD5

please make the disabilitation possible via the auth_login variable.

thank you.

Reproducible: Always

Steps to Reproduce:
1.connect to an imap server that does not support cram-md5
2.
3.

Actual Results:  
the connection is closed and the authentication fails.

Expected Results:  
correct authentication on the server.
(Assignee)

Comment 1

15 years ago
try running a 1.5 build - there's a UI for disabling it there. Also, in the
latest 1.4rc2 build, cram-md5 is disabled by default for imap.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Bug 205003 fixed this with a preference (will be fixed in 1.4RC2)
Bug 205571 added an UI for it (will be in 1.5a)

The preference is "mail.server.default.useSecAuth", and default is off.

see bug 208026 comment 14

*** This bug has been marked as a duplicate of 208026 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.