back/forward button history items inherit the tooltiptext from the button ("go back/forward one page")

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Chris, Unassigned)

Tracking

({polish})

Trunk
polish
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

If I open the back button's history and hover over an item in the history, the
popup is a small empty box.  If I hover over the back button so the "Go back one
page" tooltip appears, this message will appear when hovering over an item in
the back button history.

Reproducible: Always

Steps to Reproduce:
1. Visit enough webpages to have a back button history (2)
2. Open the back button history
3. Hover on an item in the back button history
Actual Results:  
As described in Details.

Expected Results:  
No popup, or perhaps the page's url?

I sincerely apologize if this bug is a duplicate, I looked through the list and
couldn't see a similar bug there.  I'm also sorry if I used the wrong
terminology, I'm winging it.
This one is weird, do we even want tooltips on history dropdowns?  Maybe, maybe
not, but the tiny box is weird.

-->
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726 Mozilla
Firebird/0.6.1

The small box effect is fixed on this build, the browser displays the url for
the hovered history page. However the "Go back one page" problem still exists.

Comment 3

14 years ago
*** Bug 219652 has been marked as a duplicate of this bug. ***

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago
As far as I can tell, Bug 219652 is not a duplicate of this bug.  Bug 219652 
specifically relates to the drop-down arrow next to the back button, and the 
misleading tooltip that appears when hovering over it.

This bug, however, if I understand it correctly, is more related to the pop-up 
menu that appears when you actually view the back button history.  If you hover 
over the back button history arrow long enough to view the tooltip that 
says "Go back one page" and then view the URL(s) listed in the history pop-up 
menu, their subsequent tooltips say "Go back one page."

So in essence, if Bug 219652 were to be fixed (e.g. changing the tooltip to 
read "View back history"), this bug would most likely still persist.  URLs in 
the pop-up history would simply have tooltips that read "View back history" 
instead of "Go back one page."

Can someone confirm that my understanding is correct?

Comment 5

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040411
Firefox/0.8.0+
I've seen the empty tooltip here. Also I noticed that if you hover the back
button itself and see the "Go back one page" tooltip, then open the dropdown
list and hover an entry there, you'll see the same "Go back one page" tooltip
instead of the empty one.

I agree with Bernie (comment 4) that bug 219652 is not a dup of this one.

IMO there should be tooltips with URL, and it's I think is easy to fix (actually
I got it working for me).

Comment 6

14 years ago
Created attachment 147078 [details] [diff] [review]
Show URLs instead of blank tooltips

Perhaps somebody could test it out...

Comment 7

14 years ago
This bug depends on bug 117377

Comment 8

14 years ago
I have found the same problem here, but under further investigation it appears
that the tooltip that appears when hovering over any back button history is the
same as whatever the last tooltip on that toolbar displayed was.

For example, if you hover over the 'reload page' button on toolbar, then go to
the down arrow on the back button and expand. Move down the list of sites in
back button history and notice that the tooltip now reads 'Reload current page'
(as in the reload tooltip). This also happens when you hover over the 'Home'
icon. whatever tooltip is displayed there will subsequently be displayed in the
back button history as tooltip.

In a nutshell, the last tooltip to have been displayed on that toolbar is the
one which appears. (Hover over fav/icon in address bar and you get a tooltip
there which also displays on back button history tooltips).

What should be showing (for each back button entry) IMHO is:

   Page Title    {i.e. <title>Whatever is here</title>}
   http://www.a.url.com/index.htm    {truncated after so many chars}

Updated

14 years ago
Flags: blocking1.0?

Updated

14 years ago
Flags: blocking1.0? → blocking1.0-

Comment 9

13 years ago
Richard seems to have found the crux of this. The "small empty box" effect is
likely caused when there hasn't been another tooltip yet displayed since Firefox
started. Actually, just tested: it's per-window.

Presumably, normal tooltips are shown with "set tooltip=foo; show_tooltip();".
And it looks like the entries in back's history just do "show_tooltip();".

Interesting that the back button's context menu doesn't exhibit this behavior.
There are no tooltips displayed when you right-click the back button and hover
over THAT menu's entries.

Reseting severity because not showing the URL is a usability issue, especially
when navigating through pages that use unhelpful and/or identical <title>s. This
also affects the forward menu in the same way, so updating summary.
Severity: trivial → normal
OS: Windows 98 → All
Hardware: PC → All
Summary: Incorrect popup under back button history → Incorrect tooltip popups under back/forward button history

Comment 10

13 years ago
"Mozilla Firefox Help" (F1) has exactly the same problem with it's back (and
forward) button(s).

This issue appears to be a wider problem than first thought, should I raise a
separate bug for the Help window, or just change the summary of this one to
include the Help console?

Comment 11

13 years ago
*** Bug 269113 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
Dup of bug 147670?

Comment 13

13 years ago
I'd leave it until bug 147670 is fixed.
Depends on: 147670

Comment 14

13 years ago
*** Bug 278309 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Keywords: clean-report, polish

Comment 15

13 years ago
Created attachment 178229 [details]
Picture of bug-in-action.

Here's what the bug looks like.

Updated

13 years ago
Blocks: 276622

Updated

12 years ago
Flags: blocking1.8b5?
Assignee: firefox → nobody
No longer blocks: 276622
Keywords: clean-report
QA Contact: history

Comment 16

12 years ago
no patch, not a regression over 1.0 and not serious enough for us to stop the
release. Hopefully someone will work on this for the next release. 
Flags: blocking1.8b5? → blocking1.8b5-

Comment 17

12 years ago
On 10x XP Home, Pro SP1+2 systems I used Firefox on, this seems to be a problem.
 More precisely, when hovering over the main BACK button itself you can see the
thinner button of back pages dropdown (mini history) but when you hover over it,
the divide disapears, meaning its not clear which button or function is being
hovered over or about to be pressed.

 The tooltip stays the same of GO BACK ONE PAGE, when for that function,
that is plainly false.  It will infact open a dropdown of pages going back many
pages, like a mini history, to then click on.  This seriously needs fixing, its
misleading, confusing, not like any other browser or product, and plainly just
wrong.

Comment 18

12 years ago
(In reply to comment #17)
That's bug 219652. Comment 8 basically sums up this bug (although it's more general -- see comment 10).


Btw, is there any reason this isn't a dupe of bug 147670? With that fully fixed this should no longer happen, right?
The core issue, bug 147670, was fixed, but that fix made apparent another issue: the items themselves have no defined tooltips, so they inherit the tooltip of their parent (the back button).
Severity: normal → trivial
No longer depends on: 147670
Summary: Incorrect tooltip popups under back/forward button history → back/forward button history items inherit the tooltiptext from the button ("go back/forward one page")

Comment 20

12 years ago
Although, in bug 147670 comment 126 it sounds like Steffen is saying this can't be fixed (yet, on trunk) by adding tooltips to the menuitems. If he does get around to opening a new bug on that, this one should depend on it.

Comment 21

12 years ago
Why is nobody working on this and related issues?  This is serious UI bug and contradiction that needs attention.

Comment 22

12 years ago
(In reply to comment #21)
> Why is nobody working on this and related issues?  This is serious UI bug and
> contradiction that needs attention.
> 

You might wanna read the following before making such comments:
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Comment 23

12 years ago
Isn't this a 'Toolbars' component issue, rather than 'History'?
And the summary would be more accurate if it said "back/forward drop-down items inherit the tooltiptext from the latest button whose tooltiptext appeared".

Comment 24

11 years ago
I would like to clarify something I've observed with respect to this bug:
The tooltip which appears is not necessarily the tooltip of the parent, but the last tooltip which was shown.  For example, if one clicks on Forward history, then hovers over the "Reload Button" to get the "Reload current page tooltip", then hovers over an item in the Forward History List, the "Reload current page" tooltip appears.  Using 1.7.13 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060417) from mozilla.org

Comment 25

11 years ago
I see the same manner too under IE (This is for diddykong comment[This seriously needs fixing, its misleading, confusing, not like any other browser or product])

To me as an user i would like to keep the tooltip only for the back button saying (Go back one page) and for the side by list button to hold no tooltip or can have something like (Press/Click). There no point in having the button to list while clicking and also to list while hovering.   
This affects all toolbar buttons of type "menu" or "menu-type" and not just the back and forward buttons.

For example it affects the search button (hover over the "Manage Search Engine..." text and you'll see it).

It is also affecting my extension that puts a button of type "menu-type" in the toolbar.  All menuitems in that popup menu display the toolbarbutton's tooltip.  A menuitem with it's own tooltiptext attribute will display that text as the tooltip, but ones without a tooltiptext attribute will display the parent button's.

See bug 374288

Comment 27

11 years ago
OK, so the concern in comment 19 is the same thing that filed in bug 374288. Marking as dependency, although it's really the same. Will move that bug to Core.
Depends on: 374288
Version: unspecified → Trunk

Updated

11 years ago
No longer depends on: 374288

Updated

11 years ago
Depends on: 374288
Tooltips would be nice if they gave the url, although none would be preferable to the current behavior, and maybe none is the right behavior since the menu will be wide enough to fit the page title most of the time.

Updated

10 years ago
Duplicate of this bug: 385890

Comment 30

10 years ago
I can't reproduce in Firefox 3.0 on Windows XP. Can anyone give steps to reproduce in any Firefox 3.x build?
It appears bug 374288 has been partially fixed somehow in Firefox 3.0.  Specifically that the "tooltiptext" attribute no longer propagates to child items in a menu.  The "tooltip" attribute still does, but since the back/forward button uses "tooltiptext" the problem described in this bug is no longer an issue.
Actually I double checked the back/forward button and it appears that every menu item has it's own specific tooltiptext.  So this bug would no longer be valid even if bug 374288 wasn't partially fixed.
fx3 on linux: back/fwd recent pages menu has "go back to this page" "stay on this page" "go forward to this page" depending on shistory position -> wfm
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
s/menu has/menuitems have/ even

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.