status bar changes when Javascript prefetches images after a page's onLoad

VERIFIED DUPLICATE of bug 209330

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 209330
15 years ago
10 years ago

People

(Reporter: Jonathan Feinstein, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030507

The page at http://www.killerinstinct.com/bugsample.html demonstrates a user
interface problem that seems to have started with Mozilla 1.3b. When JavaScript
is used to prefetch images *after* the page has finished loading, the following
text flashes in the status bar: "Waiting for somehost..." and "Transferring data
from somehost...". This is inconsistent with MSIE 6.x and is inconsistent with
Mozilla 1.2.1 and 1.3a. Most importantly, it is potentially very disruptive to a
user's experience: cyclical changes that occur to the browser's "chrome" give
the impression that the page is still loading and distract the user from any
page contents that are already displayed. This is fine if the page truly is
still loading, but once it has finished such changes should be suppressed to
avoid distracting the user from the page content.

Clicking the button below causes the browser to prefetch 100 images. In Mozilla
1.2.1, Mozilla 1.3a and MSIE 6.0, no visible change to the status bar occurs. In
Mozilla 1.3b->1.4b, messages are flashed repeatedly.

JavaScript image preloading is commonly used to pre-cache sets of images that
may be needed on subsequent pages.  Web site publishers who want to support
Mozilla will likely be unwilling to use this feature if it makes their pages
appear to continue loading.  This feature is also sometimes used to precache
images that must be displayed inline on mouseover.  A message in the status bar
is not desirable in this case, either.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.killerinstinct.com/bugsample.html
2. Make sure that the page has finished loading.
3. Click the button.

Actual Results:  
The status bar very quickly flashes the message "Waiting for
www.killerinstinct.com...", then changes to "Transferring data from
www.killerinstinct.com...", and repeats this 100 times.  When it finishes, it
leaves the message "Transferring data from www.killerinstinct.com..." in the
status bar even though nothing is being transferred.

Expected Results:  
Mozilla should have left the status bar empty and given no indication in the
browser chrome that anything was happenning.

This bug occurs with both the classic and modern theme.

*** This bug has been marked as a duplicate of 209330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.