Closed Bug 209378 Opened 18 years ago Closed 18 years ago

bad javascript with html languages other than english

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 101600

People

(Reporter: andyice2, Assigned: rogerl)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.3) Gecko/20030312

During site construction I observed that the same javascript, on the same page
runs wrong if the html page is not in english. I intend the code in the first
line     of the code "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN">"
See the examples I uploaded here:
http://andyice2.altervista.org/mozilla/en.htm      right
http://andyice2.altervista.org/mozilla/it.htm      wrong



Reproducible: Always

Steps to Reproduce:
See the examples I uploaded here:
http://andyice2.altervista.org/mozilla/en.htm      right
http://andyice2.altervista.org/mozilla/it.htm      wrong
*** Bug 209379 has been marked as a duplicate of this bug. ***
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//IT"> is invalid HTML. Those only gives the language of the Markup (never used in 
real-live). If you want to mark a website as being Italian, write <html lang="it">. 
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
v
Status: RESOLVED → VERIFIED
reopening to dupe against 101600
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 101600 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Verified duplicate.

Andrea, thank you for this report. You have been cc'ed on bug 101600
so you can follow progress on this issue -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.