bad javascript with html languages other than english

VERIFIED DUPLICATE of bug 209378

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 209378
15 years ago
15 years ago

People

(Reporter: Andrea Mirabilio, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.3) Gecko/20030312

During site construction I observed that the same javascript, on the same page
runs wrong if the html page is not in english. I intend the code in the first
line     of the code "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN">"
See the examples I uploaded here:
http://andyice2.altervista.org/mozilla/en.htm      right
http://andyice2.altervista.org/mozilla/it.htm      wrong

Reproducible: Always

Steps to Reproduce:
See the examples I uploaded here:
http://andyice2.altervista.org/mozilla/en.htm      right
http://andyice2.altervista.org/mozilla/it.htm      wrong

*** This bug has been marked as a duplicate of 209378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Verified duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.