Thread Pane: column headers for Threads, Read, Junk, Flag/Star have different width

RESOLVED DUPLICATE of bug 383913

Status

SeaMonkey
MailNews: Message Display
--
trivial
RESOLVED DUPLICATE of bug 383913
15 years ago
11 years ago

People

(Reporter: Matthias Bockelkamp, Assigned: Henrik Lynggaard Hansen)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checkin?)

Attachments

(7 attachments, 4 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030611
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030611

The coulum headers for the "sign columns" (Threads, Read, Junk, Flag) have
different witdth. I think they should have the same because the size of the
images is the same. I'll attach a screenshot.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 125646 [details]
Screenshot of column headers
(Reporter)

Comment 2

15 years ago
Created attachment 125648 [details]
Sorted for better view
(Reporter)

Comment 3

15 years ago
This is caused by the used gif images, some are 16x16 and one is 18x16. I'll
attach the changed ones. But the junk icon still looks ugly, because the Junk
box isn't centered (it is centered in the used gif).
(Reporter)

Comment 4

15 years ago
Created attachment 125650 [details]
All images resized to 18x16
(Reporter)

Comment 5

15 years ago
Created attachment 125651 [details]
Screenshot of column headers (with fixed images)
(Reporter)

Comment 6

15 years ago
Created attachment 125652 [details]
Sorted for better view (with fixed images)

It seems there is still a problem with the with of the junk colum header.
(Reporter)

Comment 7

15 years ago
The ugly Junk box can be fixed by changing threadPane.css:

/* ..... junkStatus column ..... */

treecol.junkStatusHeader {
  list-style-image: url("chrome://messenger/skin/icons/folder-junk.gif");
  padding: 0px 4px 0px 0px;
}

The other column headers don't have the "padding..." line. Removing it solves
the problem. I'll attach screenshots again.
(Reporter)

Comment 8

15 years ago
Created attachment 125653 [details]
Screenshot of column headers (with fixed images and changed threadPane.css)
(Reporter)

Comment 9

15 years ago
Created attachment 125654 [details]
Sorted for better view (with fixed images and changed threadPane.css)
(Reporter)

Comment 10

15 years ago
I can't set the Review flag for this bug because there is no attached patch. So
I'm asking for Review this way.
(Assignee)

Comment 11

15 years ago
Hi 

Could you please attach the altered version of threadPane.css, and I will be
happy to convert it to a patch and submit it for review.

btw. Have you checked to see if the problem also appears in the modern theme,
and perhaps in thunderbird ?

Assignee: sspitzer → admin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 12

15 years ago
The problem doesn't appear in Modern theme, but it's also present in
Thunderbird. A patch for threadPane.css will follow.
(Reporter)

Comment 13

15 years ago
Created attachment 128245 [details] [diff] [review]
patch
(Assignee)

Comment 14

15 years ago
Comment on attachment 128245 [details] [diff] [review]
patch

The images in the zip file is part of the fix.
Attachment #128245 - Flags: superreview?(jaggernaut)
Attachment #128245 - Flags: review?(jaggernaut)
(Assignee)

Comment 15

15 years ago
Created attachment 128255 [details] [diff] [review]
Patch for the thunderbird. It has the same problem.

Please note that like the patch for the app suite the images in the zip file is
part of the fix
(Assignee)

Comment 16

15 years ago
Hi mscott,

I was told on irc that you are the man for thunderbird fixes, could you please
review the patch.

Comment 17

15 years ago
Comment on attachment 128255 [details] [diff] [review]
Patch for the thunderbird. It has the same problem.

I can check the thread pane change into thunderbird.

Interesting for me, the junk mail icon looks centered in my build.
Attachment #128255 - Flags: superreview+

Comment 18

15 years ago
I'm just going to go ahead and check the thread pane change in for thunderbird.
Hopefully the resized images will soon follow into the trunk. 

Feel free to use me as an r or sr for the trunk threadPane.css change for
classic too.

Comment 19

15 years ago
mailWindow1.css and searchDialog.css need to be patched instead of/along with
threadPane.css for thunderbird.
(Reporter)

Comment 20

15 years ago
Created attachment 128328 [details] [diff] [review]
updated Patch for Mozilla

Updated Patch for Mozilla. Also centers the "readmail.gif" in the colums.
Attachment #128245 - Attachment is obsolete: true
(Reporter)

Comment 21

15 years ago
Created attachment 128329 [details] [diff] [review]
updated Patch for Thunderbird

Updated Patch for Thunderbird. Also centers the "readmail.gif" in the colums.
Obsoletes #128255 (I can't set that).
(Reporter)

Updated

15 years ago
Attachment #128328 - Flags: superreview?(scott)
Attachment #128328 - Flags: review?(scott)
(Reporter)

Updated

15 years ago
Attachment #128329 - Flags: superreview?(scott)
Attachment #128329 - Flags: review?(scott)
(Reporter)

Updated

15 years ago
Attachment #128245 - Flags: superreview?(jaggernaut)
Attachment #128245 - Flags: review?(jaggernaut)

Updated

15 years ago
Attachment #128329 - Flags: superreview?(scott)
Attachment #128329 - Flags: superreview+
Attachment #128329 - Flags: review?(scott)
Attachment #128329 - Flags: review+

Updated

15 years ago
Attachment #128328 - Flags: superreview?(scott)
Attachment #128328 - Flags: superreview+
Attachment #128328 - Flags: review?(scott)
Attachment #128328 - Flags: review+
(Reporter)

Comment 22

15 years ago
I just saw in CVS Log (1.16 -> 1.17) of threadPane.css that the now deleted
padding was inserted because of a cropped thread pane Junk icon on Mac (Bug
#194567). So if this is checked in, it should be checked carefully on the three
main platforms.
(Reporter)

Updated

15 years ago
Attachment #125651 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #125652 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #128255 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #125650 - Flags: superreview?(scott)
Attachment #125650 - Flags: review?(scott)

Comment 23

14 years ago
that bug's currently open (again), could someone test the patch on macosx and
then check this in if nothing interesting is present.
Keywords: qawanted
Whiteboard: checkin?
(Reporter)

Comment 24

14 years ago
Comment on attachment 125650 [details]
All images resized to 18x16

trying other reviewer/superreviewer...
Attachment #125650 - Flags: superreview?(mscott)
Attachment #125650 - Flags: superreview?(blizzard)
Attachment #125650 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #125650 - Flags: review?(mscott)

Comment 25

14 years ago
Comment on attachment 125650 [details]
All images resized to 18x16

You can't change the size of folder-junk.gif because the folder pane uses it.
Attachment #125650 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Reporter)

Updated

14 years ago
Attachment #125650 - Flags: superreview?(blizzard)
Product: Browser → Seamonkey
*** Bug 209414 has been marked as a duplicate of this bug. ***

Comment 27

13 years ago
looks just fine to me in SM 1.5 nightly as shown in attachment 125653 [details]

Comment 28

13 years ago
hasn't been checked in according to Matthias

"see <http://lxr.mozilla.org/seamonkey/source/themes/classic/messenger/threadPane.css#117> and the bug still exists. ...width of the column headers (values are taken from my actual sm 1.5+): threads 25px, read 23px, junk 24px, flag 23px. They should be all equal."

Comment 29

12 years ago
Does the TB patch here still apply to the new theme?
Summary: Thread Pane: column headers for Threads, Read, Junk, Flag have different width → Thread Pane: column headers for Threads, Read, Junk, Flag/Star have different width
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383913
You need to log in before you can comment on or make changes to this bug.