top image misaligned in page render

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Robi, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030614 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030614 Mozilla Firebird/0.6

In the page at http://robione.com/, logo image at the top should be alligned
with the page and other connecting image(s). In Phoenix(FireBird), the logo
image is not alligned to the rest of the page and images.

Reproducible: Always

Steps to Reproduce:
1. Open browser
2. ctrl-k
3. robione.com <enter>

Actual Results:  
logo image misaligned

Expected Results:  
flush logo image display with rest of page

Comment 1

15 years ago
I can confirm the problem of misaligned logo in the upper left corner using
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030615 Mozilla
Firebird/0.6, but this can also be seen suing latest SeaMonkey.

=> should be moved over to product "Browser" after searching for possible dupes

Did some testing and found that the problem is caused by a comment placed within
the style section defining the styles of the upper three links "client login",
"webmail" and "customer service":

<style type="text/css">

<!-- there is a comment -->

<!-- 
.
.
and here finally follows some style definitions
.
.
-->

If I remove the comment the styles are used and the fonts for the links is
smaller, causing the eable to look ok. If the comment is within the style
definition section, the styles seem not to be used (the font for the link is
larger) and the logo looks misplaced within the table - but the original cause
is the way too large font for the link.

=> adding two reduced testcases for this
OS: Windows 98 → All

Comment 2

15 years ago
Created attachment 125732 [details]
Here the font for the links is larger and the logo looks misplaced

Comment 3

15 years ago
Created attachment 125733 [details]
Here the font for the link is smaller since the styles are used and the logo looks ok

Comment 4

15 years ago
Did some further search on Bugzilla and found a comment made by David Baron,
where <!-- and --> are mentioned to be NO valid CSS comments (see
http://bugzilla.mozilla.org/show_bug.cgi?id=201580#c1).

=> resolving this one as "invalid" since this is obviously a coding error! Robi,
I don't know whether you are the site author or not, but if so, please change
the coding and use /* and */ for comments. Otherwise please feel free to reopen
bug so we can change it over to Tech Evangelism so we can contact the site
administrator and ask them to change the coding.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.