bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firebird 0.6 fails to launch when any URL is clicked in Thunderbird (when using Firebird as default browser)

VERIFIED WORKSFORME

Status

()

Firefox
Build Config
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Gordon Griswold, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

While using Firebird as default browser and Thunderbird (061303 Build) as
default E-Mqail client the following occurs whenever a URL is clicked in a
HTML-formatted message, the following error message is issued by Thunderbird: 
"Error launching browswer window
TypeError:Components.classes['@mozilla.org/appshell/component/browser/instance.1']
has no properties." 

When using Thunderbird with other default browsers, i.e. Safari, Thunderbird and
Safari link properly whenever a URL is clicked in a message within Thunderbird.

Firebird works properly with other e-mail clients such as GNUMail, Mail.app, etc.

Reproducible: Always

Steps to Reproduce:
1.Set Firebird as default browser in OSX.
2.Set Thunderbird as default e-mail client in OSX.
3.Click on Thunderbird's throbber, or any URL in a HTML-formatted email message

Actual Results:  
See details.

Expected Results:  
Firbird should have gone to the web site represented by the URL in the e-mail
message.

Talkback was not invoked.  To clear the error message in Thunderbird I had to
force quit the app and relaunch it.

Comment 1

15 years ago
This WFM using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030615
Mozilla Firebird/0.6 together with Mozilla Thunderbird 0.1a (20030603) =>
Mozilla firebird opens the clicked URI without any problems.

Did you give it a try using latest nightly of Mozilla Firebird, installed in a
new directory and using a fresh / vanilla profile?

Comment 2

15 years ago
via mail:

>Hi-
>I tried your suggestion with the same results as noted in my bug
>report. I used the 2003-06-11-Trunk of Firebird dated 12-Jun-2003 and
>the 20030615 Mozilla Firebird/0.6 version of Firebird. Got the same
>errors noted in my bug report #209484. Please not the following:
>
>1. I use the Mach0 versions of Thunderbird and Firebird; not the
>
>"Windows; U; WinNT4.0; en-US; rv:1.4b" version of this software.
>
>2. As I stated in my original submission, Firebird works fine with OTHER
>Mac OSX E-Mail clients.
>
>3. This problem may be unique to Thunderbird for Mac OSX.
>
>4. The problem is consistently repeatable under OSX 10.2.6.

=> not sure if this is really a Moz.Firebird issue - adding keyword & status
Keywords: qawanted
Whiteboard: needs to reproduce on Mac
(Reporter)

Comment 3

15 years ago
Note: If Firebird is already launched Thunderbird will correctly link/switch to
the browser.  Problem manifests itself if Firebird must launch cold-turkey in
response to a url beind clicked in Thunderbird. Other browsers work fine with
Thunderbird, e.g. Safari, iCab, etc. Currently running Thunderbird with Mac OS
10.2.6. All other TBird functions appear to work correctly. 

Comment 4

15 years ago
The error message below more generally comes up whenever trying to use the
"-remote" command with MozillaFirebird if Thunderbird if presently running.

"Error launching browswer window
TypeError:Components.classes['@mozilla.org/appshell/component/browser/instance.1']
has no properties." 

Start Firebird
Start Thunderbird
exec MozillaThunderbird -remote "openURL(about:, new-tab)"
/error msg/

Comment 5

15 years ago
This bug also appears when using other applications that try to open links in
Firebird. For example, if Thunderbird, Firebird, and NetNewsWire Lite (for
example) are all loaded, and a link is clicked on in NetNewsWire Lite, the error
message appears in Thunderbird. This should be sent to Firebird, not Thunderbird.

Thunderbird is set as the default mail program and Firebird is the default browser.

Comment 6

15 years ago
I have a similar problem in linux. Thunderbird won't open any browser when I
click on a link. Not in Gnome, not in KDE, not when Firebird is running and not
if it's closed.

Shouldn't there be an interface for selecting wich browser to use, if it can't
query the current DE (Gnome, KDE, etc..) and ask which browser it should use?

Comment 7

15 years ago
ugh, something about launching links in firebird is pretty broken.  see my
comment in bug 210553.  as for this particular bug (cold start), it is now WFM
in smartasfuck.com build 20030821.

Comment 8

15 years ago
Marking WFM as per last comment. Please reopen, if you still see this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

15 years ago
09-05003 I just tried to link from Thunderbird 0.2 to Firbird Build # 20050904 using my iMac 
and OSX 10.2.6.  The following error message was issued by Thunderbird: 'Error launching 
browser window:TypeError:Components.classes["@mozilla.org/appshell/component/browser/
instance;1"]has no properties'  This problem appears to be FB-specific on the Mac when using 
TB in combination with FB.  TB works correctly with Camino, Safari, etc.  this bug can be 
reproduced with consistency on my Mac. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

15 years ago
QA Contact: asa

Comment 10

15 years ago
*** Bug 221880 has been marked as a duplicate of this bug. ***
Gordon, Jonathan, can you both still reproduce this with a current build?

Updated

15 years ago
QA Contact: bugzilla
(Reporter)

Comment 12

15 years ago
As of 11-06-03 Bug 209484 can still be reproduced with the latest nightly builds
of FB and TB on my Mac.  I am now using OSX 10.2.8.  
Summary: Firebird 0.6 fails to launch when any URL is clicked in Thunderbird (when usinf Firebird as default browser) → Firebird 0.6 fails to launch when any URL is clicked in Thunderbird (when using Firebird as default browser)
Gordon, could you test again with a current fb build and thunderbird 0.4
The thunderbird release notes say, that this is fixed
(Reporter)

Comment 14

15 years ago
This bug can be closed, as far as I am concerned.  The latest nightly builds9 as
system defaults) of BOTH FB and TB successfully talk to each other on my iMac,
with OSX 10.2.8.  Thank you for fixing this bug!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
WFM is the correct resolution. Please only use FIXED when you can pinpoint an
issue to a checkin
Status: RESOLVED → UNCONFIRMED
Keywords: qawanted
Resolution: FIXED → ---
Whiteboard: needs to reproduce on Mac
re-resolving
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
verified by reporter.
Status: RESOLVED → VERIFIED

Updated

13 years ago
QA Contact: bugzilla → build.config
You need to log in before you can comment on or make changes to this bug.