mail messages displayed wrong if no Date header in message

VERIFIED DUPLICATE of bug 73565

Status

MailNews Core
Database
VERIFIED DUPLICATE of bug 73565
15 years ago
9 years ago

People

(Reporter: Kresimir Tonkovic, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Sometimes I receive mail messages with no "Date" header. Such messages are
displayed with the date 6th Feb 2101. 6:28am. The messages do contain valid
dates in the "Received" header, and this works fine in Outlook Express.

Reproducible: Always

Steps to Reproduce:
1.Export a mail message into a file
2.Edit the file; delete the line containing the "Date" header
3.Import the message back into Mozilla mail (my recipe involves outlook express,
but there are probably better ways :-)
4. Open the folder containing the message

Actual Results:  
The message line in the folder listing has an invalid date: 6th Feb 2101. 6:28am

Expected Results:  
parsed the Received header and extract the message date from there

Comment 1

15 years ago
Bug 207045 was duped against bug 73565. Most people seem to see a 01/01/1970
date (minus the timezone-diff), but some seem to see some kind of garbage data.
Outlook seems the get the date from another header (the received-headers), so if
you import it via Outlook, then Mozila might get it from another header, added
by Outlook.

Reporter, can you post all the headers of this message (after it was imported in
Mozilla) ? Replace private data if you need, but leave in anything that look
like a date, especially the received-headers.
(Reporter)

Comment 2

15 years ago
These are the message headers as shown by Mozilla mail's view message source: 

From - Mon Jan 1 00:00:00 1965
Received: (qmail 21508 invoked by uid 1004); 22 May 2003 15:13:35 -0000from 
unknown (HELO xxx.xxx.com) (217.14.214.82)by 0 with SMTP; 22 May 2003 15:13:35 -
0000(qmail 12139 invoked by uid 1004); 22 May 2003 15:13:37 -0000from unknown 
(HELO localhost) (217.14.214.82)by 0 with SMTP; 22 May 2003 15:13:37 -0000
From: xxx@xxx.com
Reply-to: xxx@xxx.com
To: yyy@xxx.com
X-mailer: AlterUM v1.0
X-alter-sendrequest: 102
Subject: =?utf-8?B?RndkOiBSRTogUG96ZHJhdiBpeiBBbHRlcmJveGEuLi4=?=
X-MsgID: 296044
MIME-version: 1.0
Content-Type: multipart/alternative;
	boundary="Message-Boundary"

Comment 3

15 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624]

Something similar happens if the Date Header is present but invalid. Example
header from a (Junk-)Mail i got today:

Date: sam., 19 juil 2003 12:37:37 -0600

In the "Date" column in the mail folder window, "01.01.1970 01:00" (time_t=0 +
DST) is shown. But in the mail window, some funny random date like "28.11.10024
00:36" is shown. Every redisplay of the mail changes this value. Possibly
uninitialized variable).

Separate or same bug?

Comment 4

14 years ago
Christian, your bug is probably bug 32216. This one is most certainly a dupe of
bug 73565.

*** This bug has been marked as a duplicate of 73565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core

Comment 5

11 years ago
V/dupe.
QA Contact: esther → benc

Updated

11 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.