Closed Bug 209527 Opened 17 years ago Closed 17 years ago

microsoft.com - Comment closed improperly and text missing

Categories

(Tech Evangelism Graveyard :: English US, defect, P2)

x86
Windows 2000
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: golam, Assigned: owen.marshall+bmo)

References

()

Details

(Whiteboard: [om:6/24])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

"View source" displays different results for IE and Mozilla.
In Mozilla "View source" there is no opening comment tag at some point:
"------Begin station box Fort Bush---->"
But it is in IE view source:"<!------Begin station box Fort Bush---->"
Microsoft diversion?

Reproducible: Always

Steps to Reproduce:
Confirmed (Phoenix 0.6, Linux)

When you save the file (file -- save as) and view the HTML, we see this:
  <!---->------Begin station box Fort Bush----&gt;

The --> closes the comment and the rest is displayed. (As per specification, I
must add -- HTML 4 section 3.2.4)
Assignee: english-us → malachi
Tech Evangelism Triage:
Accepting. Letter sent using Microsoft email feedback link, awaiting site response.

Changed summary. Have no IE to test on -- is this the only issue?

keyword-->evang500
priority-->p2
milestone-->July

Will follow up with second letter if no response by June 23.
Status: NEW → ASSIGNED
Keywords: evang500
Priority: -- → P2
Summary: Not all the content is displayed → microsoft.com - Comment closed improperly
Whiteboard: [om: 6/23]
Target Milestone: --- → Jul
Followup Recieved from Microsoft:
"Hello and thank you for writing to Microsoft.com.  
  
Please be informed that we have looked at this problem on our live servers.  
However, we are not able to see any instance in our code where there's an 
improperly placed chevron, or a &gt on that page.   
  
Please accept our apologies for the trouble you have encountered while reading 
the page. We appreciate for taking the time to point this out to us."

Tested on IE6 -- The IE code displays this:
<!------Begin station box Fort Bush---->

Also: I think quite a bit of the page is missing, IIRC.

I have no clue... sending back to TE main address for future triage (since I am 
clueless ;-()
Assignee: malachi → english-us
Status: ASSIGNED → NEW
QA Contact: english-us → malachi
Summary: microsoft.com - Comment closed improperly → microsoft.com - Comment closed improperly and text missing
Whiteboard: [om: 6/23]
Owen, since you have already contacted them, please follow up with them with the
following information.

The problem is that this is in Standards mode and in XHTML.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

and they are using invalid comments like

<!----End station box Sugarland---->

You can point them to http://devedge.netscape.com/viewsource/2003/comments/ for
more information.
Followup letter sent via form submission. Will follow-up by June 24 if no
additional contact recieved.

(Frankly, I was suprised by the speed of the response ;-))
Assignee: english-us → malachi
Whiteboard: [om:6/24]
Blocks: MS
fixed
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
*bugspam*
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.