no password asked for pop3 account

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: DuSti, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

My linux system is Dedian stable. 
I upgraded the mozilla 1.0 to 1.4b and all went fine except that i can t check
my mail anymore. I get the error "conection to mail-in.pandora,be timed out" 
I think there is an authentification problem. 

I tried reentering the account but when I try to check the pop3 mail I don t get
a question for a password. 

there also doesn't seem to be a field to fill in a pop3 password. 



Reproducible: Always

Steps to Reproduce:
1. removing the existing account
2. creating  a "new" account
3. trying to check mail

Actual Results:  
no connection is being make to the pop3 mail server

Expected Results:  
checking the mail

Comment 1

15 years ago
*** Bug 209536 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
please try an rc2 build - I think this has been fixed, and is a dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Hi,

How can I get RC2? I just dl'ed the nightly build but it didn't fix the problem.

btw, I've seen this problem on both hp-ux and windows xp.

Sory to bother you but this is urgent for me. Until this is fixed I can only use
Outlook. Ugh -- I can't figure out how to do anything in Outlook.
(Reporter)

Comment 4

15 years ago
I found a solution for now, 
It aint perfect and I had to download all my email messages again but anyway...
I just deleted my .mozilla folder in my home dir and then I created the account
again and I could check my email. 

So I guess that something goes wrong when mozilla 1.4b converts the 1.0 profile
settings. 
should I reinstall mozilla 1.0 and then install the rc2 build to find out if its
already been solved? (I have time since I'm unemployed at the moment...)

DuSti

Comment 5

15 years ago
I may have misunderstood what's going on here. When you say you downloaded the
nightly build, was it a 1.5 build, or a 1.4 rc build? help | about should tell
you. It sounds like something in your profile was messed up, though I'm not
really sure it was a migration problem. If you're running a 1.5 build, there
should be a setting in the server settings for your pop3 server that says "use
secure authentication". It should be unchecked. But your problem sounds a little
more like a proxy config issue if you're not getting to the pop3 server at all.
(Reporter)

Comment 6

15 years ago
Mozilla 1.4b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

is the build that I downloaded and installed with the mozilla-installer.
(so it s not the latest nightly build) 
About the possible proxy config isue: I could get online with the browser and I
could ping to the mail server (or has this nothing to do with it?) 

schould I try the install again (removing 1.4b, installing 1.0 and installing
1.4b again) or (removing 1.4b installing 1.0 and install the latest...) 

I wana help testing I might even learn something new ;-)

DuSti


Comment 7

15 years ago
DuSti, you should try downloading 1.4rc1 or 1.4rc2 and see if that works.
Pinging the mail server doesn't neccesarily tell you everything since it might
be the particular pop3 port that's involved. Also, are you using SSL with your
pop3 server?

Comment 8

15 years ago
Hello,

I have discovered the source of my problem. It could be the same problem your
having as well....

I didn't have my pop server in the edit->pref->adv->proxies->'No Proxy For:" box.

I just added it and was able to download all my mail!

The second bienvenu said proxy issue, I realized that moz was trying to go
through my web proxy to get to the pop server. Well, In some cases that would be
the right thing to do but not in this case.

Maybe if the first attempt of connecting to the pop server times out Moz should
automatically try to connect without the proxy. It might save some people some
time and headache. I don't think it would hurt anything.

Thanks for your help,
Scott
(Reporter)

Comment 9

15 years ago
okey, 

last comment on this I guess
I assembled a test PC, did a clean install of debian and I created 2 useraccounts. 
Then I installed mozilla 1.0, created  twice the same email acount. 
In one of the accounts I enabled the master passwd and in the other account I
didn't chance the passwd. 

after upgrading to mozilla 1.4 rc2 I tried opening mail. 
For the user with disabled master-passwd I didn't had a problem, 
for the user with masterpasswd enabled I had to re-enter the masterpasswd.  

I guess that with mozilla 1.4 b something went wrong with the convertion of the
profile because my master-passwd wasn't asked and mozilla was not able to read
the password because it was encrypted.  

anyway, with mozilla 1.4 RC2 it seems to be fixed where with mozilla 1.4b I had
trouble 

Comment 10

15 years ago
Marking WFM according to reporters's comment #9.

Scott Rohde: You could file a new report with severity "enhancement" about your
idea in comment #8, but it's definitively a different issue than this bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.