An open save dialogue in one window causes other windows not to work

RESOLVED DUPLICATE of bug 74331

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 74331
15 years ago
2 years ago

People

(Reporter: Michael R. Decker, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030616

If multiple windows (not tabs) are open and a save dialogue is opened in one of
them, the other window will not work as long as the dialogue remains open.  For
example, if one clicks on 'save image as' in one window and then switches
windows without closing the dialogue, the other window (the one without the
dialogue) stops working.  This freeze only applies to web browsing.  Menus still
drop down and tabs can still be switched, but no new webs pages can be loaded. 
If the back button is hit or a url is entered, the entire window freezes
(including the menus and tabs that were thus far responsive).  Often the
animated 'm' in the upper right hand corner will go blank and be replaced by
gray.  However, once the save dialogue is closed, both windows resume normal
operation.

This does not apply to tabs, since they can not be switched as long as a save
dialogue is open in one of them.
  
It may be a duplicate of, or at least related to, bug 171286.  I am not sure.

Reproducible: Always

Steps to Reproduce:
1.With two windows open, bring up a 'save dialogue' in one of them and leave it
open.  Switch windows, and try browsing to a website.
2.???
3.Profit!

Actual Results:  
Second window (the one without the open save dialogue) freezes upon trying to
browse somehere.  Unfreezes one the save dialogue in the other window is closed.

Expected Results:  
Gone where it's told.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.