RFE: Quote message with header

RESOLVED DUPLICATE of bug 218258

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 218258
15 years ago
10 years ago

People

(Reporter: Christian Franke, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

It should be possible to quote a message including header.

Reproducible: Always

Steps to Reproduce:
1. Compose a mail
2. Options|Quote a message.
Actual Results:  
Quoted message included without header.

Expected Results:  
Quoted message (optionally) included with header.

Suggest a new menu funktion e.g
  Options|Quote with Header
or a new flag e.g.
  Edit|Preferences|Mail & Newsgroups|Compositions|Quote Messages including Header

Format of the quoted header should be like in Message|Forward As|Inline.

Comment 1

15 years ago
I cannot find a duplicate of this. It would be nice though, especially when
you're trying to forward spam and the like to your ISP. Outlook gives you a
clunky interface to get the headers, mozilla gives you nothing.

It might be nice if you view all headers to also see those in the reply.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

15 years ago
Re comment 1: (THX for confirming ;-) Forwarding Spam to ISP should include all
mail transfer related headers ("Received:"), but not mailbox internal headers
("X-Mozilla-Status").

This leads to the following additional enhancement:
  Options|Quote Message with|no Headers
  Options|Quote Message with|normal Headers
  Options|Quote Message with|all Headers ***

Same for forward message (separate bug?)
  Message|Forward As|Attachment
  Message|Forward As|Inline with normal Headers
  Message|Forward As|Inline with all Headers ***

Workaround: Copy/Paste all Headers from View|Message Source. But this includes
the mailbox internal headers.
Product: MailNews → Core

Comment 3

12 years ago
(In reply to comment #2)
> Forwarding Spam to ISP [...]
... is a complete waste of time.


> Same for forward message (separate bug?)
>   Message|Forward As|Attachment
>   Message|Forward As|Inline with normal Headers
>   Message|Forward As|Inline with all Headers ***
> 
> Workaround: Copy/Paste all Headers from View|Message Source. But this includes
> the mailbox internal headers.

Easier workaround:   View | Headers | All
followed by   Message | Forward As | Inline

This does still include the internal headers.  Don't be so sure you want those 
filtered out; there was a situation a few years ago where spam was arriving with 
X-Mozilla-Status headers already included, in order to fool the junk filter. 
(That problem was fixed.)  This is a case where you wouldn't actually want that 
header filtered out, but trying to distinguish between what was sent and what's 
been added is not simple with the basic 'mbox' format of mail.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> > Forwarding Spam to ISP [...]
> ... is a complete waste of time.
Now (two years later;-) I agree.
A function to quote with all headers would be rarely used.

But quoting with normal headers would be very useful.
When replying to an older mail, it is common to have the original mail quoted
including Date, From, To/CC headers.

I often need the following workaround to do this:
1. Message | Forward As | Inline
2. Select All, Copy
3. Cancel Compose window
4. Reply
5. Paste As Quotation

Comment 5

11 years ago

*** This bug has been marked as a duplicate of 218258 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.