stack child elements are not contained (not clipped even using overflow:hidden)

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: rvj, Assigned: David Hyatt)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

In the earlier <bulletinboard/> element I believe it was possible to have  a
number of child elements which are hidden because the x,y offsets of the child
elements were located outside of the containing box .

The current <stack/> element does not permit this and seems to have rather
unpredicatable behavior. 
a) child elements are not contained within the box but float above
b) the stack box attempts to expand to include them.

Even using overflow:hidden has no effect. I assumed that this behavior had been
reported as a bug but apparently not. 

The test case that follows has the stack element set to flex="1" . In otherwords
the fixed width boxes either side of it should be displayed. In reality the
stack element is expanded to the right.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 125799 [details]
an example of uncontained stack container child elements
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Keywords: testcase

Comment 3

11 years ago
On Windows XP SP2, Under both
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713
Firefox/2.0.0.5
and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre)
Gecko/2007072019 Minefield/3.0a7pre

I see a fixed-width gold box on the left, and a fixed-width green box on the right. This appears to be contrary to the bug report.

Therefore I'm marking this as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.