missing charavter - uparrow - in symbol font

RESOLVED DUPLICATE of bug 33127

Status

()

Core
MathML
--
enhancement
RESOLVED DUPLICATE of bug 33127
15 years ago
15 years ago

People

(Reporter: fred bisshopp, Assigned: rbs)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.75 [en]C-CCK-MCD   (WinNT; U)
Build Identifier: "firebird/1.4" IN open page

Not precisely a bug, this is a feature (now documented) of the unicode 
debate.  At the beginning of the example (above) the source contains 
¬&#173®- and the result contains мон (had to simulate that).
It looks like the unicode warriors noticed that #45 and #173 are the same 
glyph, and they decided to leave the second one out of their schemes.  Too 
bad for us math nerds because #173 is uparrow in the symbol font.  The last 
time windows/uparrow worked that I know of was with Netscape 4: I know it 
fails in IE 5 and 6, Netscape 7 and Firebird 1.4 .

(P.S. The reason for that table was so I could paste those symbols - really
easy. My hope was that ­ might be a workaround, but alas, no.)

Reproducible: Always

Steps to Reproduce:
1.I added the four extra characters before the table, and . . .
2.
3.




This really isn't your fault, but you folks seem to be the ones most likely
to come up with a fixup, and I'll be perfectly delighted if you do.  The 
rest of my equation toys seem to work pretty well on FB 1.4, with one 
exception.  I expect to find that under known problems, but if not, I'll
write another one of these for you.

Good luck! Fred

P.S. Just noticed the severity statement below.  'Guess it depends on whether 
you like math or not.
fred, this is an enhancement, not a bug, as its working as designed.  This
should also be submitted against the Browswer component as the behaviour is
present in Mozilla proper as well.  Thanks!
Not sure this will be fixed, betting it won't...
Assignee: blaker → rbs
Severity: normal → enhancement
Component: General → MathML
Product: Firebird → Browser
QA Contact: asa → ian
Version: unspecified → Trunk
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 33127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.