When installed the latest mozilla using mozilla-installer as a su, the whole envoirment got screwed up. It can't even find the command which

VERIFIED DUPLICATE of bug 69153

Status

--
major
VERIFIED DUPLICATE of bug 69153
16 years ago
14 years ago

People

(Reporter: ayanm, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: I used the latest build downloades from www.mozilla.org/start

It happened to me twice. Before I wanted to upgrade to Mozilla 1.3 using 
mozilla-installer. It screwed up the whole envoirment where no commnds could be 
find. I had to reinstall Redhat 9. then I was using the latest beta version and 
it was working. Then the webpage www.mozilla.org/start said that there is a new 
one available and I installed the mozilla-installer and follwed the steps in it 
and again the whole envoirment is screwed up. I typed which it said no which 
in /usr/bin. 

Reproducible: Always

Steps to Reproduce:
1.Use redhat 9
2.Use mozilla-installer. Do which mozilla and tell the installer to install in 
same place. It will like to delete the older version and say yes. Complete the 
process and you will see that there are commands like which and so which are 
broken.
3. There is a striking similarity in both cases I mentioned. When I tried to 
shut down there was a red flag when shutting canna server. It seems that 
mozilla-installer is screwing up canna server in redhat 9.

Actual Results:  
see above

Expected Results:  
Don't screw up my computer after I install.

Comment 1

16 years ago
Moving to the Install component. Seems more relevant. Reporter: do you know what
you were installing (was it version 1.3.1, 1.4b?)

Component: Download Manager → Installer

Comment 2

16 years ago
Where did the installer say the old mozilla version was located at?
This sounds like bug 69153
(Reporter)

Comment 3

16 years ago
1.4 Release Candidate 1.
(Reporter)

Comment 4

16 years ago
Reply to Jesiah S.

Mozilla-installer by default had the installation path as /usr/local/bin.
I did a which mozilla and found that it was in /usr/bin/. So I changed the path,
then it said it did found previous version and wants to delete it, I gave
permission.
Ayan 

Comment 5

16 years ago
what you have described is bug 69153.  the default install location is not
"/usr/local/bin", but rather "/usr/local/mozilla".  Mozilla expects that it owns
the directory it is installed to (and can therefore delete in it during uninstall).

*** This bug has been marked as a duplicate of 69153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verifying duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.