[PP] Images do not scale

VERIFIED WORKSFORME

Status

Core Graveyard
GFX
P2
normal
VERIFIED WORKSFORME
20 years ago
9 years ago

People

(Reporter: Steve Lamm, Assigned: Ramiro Estrugo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
The animated image on Test #7 does not scale.


Build stats:
----------------------------------------------------
Linux: The test platform.
Windows: The benchmark platform.
Both builds from 12-29-98.
Linux Red Hat 5.2
egcs-2.90.29 980515 (egcs-1.0.3 release)
gtk+-1.1.9
ramiro's nspr rpm with pthreads
../mozilla/configure  --enable-debug --with-pthreads
16-bit display
(Reporter)

Comment 1

20 years ago
Pam, do you know anything about this one?

Comment 2

20 years ago
I'm also seeing this bug since I updated my linux tree yesterday.
I haven't scouted recent checkins for hints as to cause.
More likely to be problem in layout than gfx stuff.

Updated

20 years ago
Assignee: michaelp → ramiro

Updated

20 years ago
Summary: [PP] Image does not scale → [PP] Images do not scale

Comment 3

20 years ago
Ditto, if you take an image (just on Linux) and try to scale it down by
percentage, it will truncate the image, rather than resize it.

For an example of this behavior, please see http://www.prometheus-music.com/
gecko/bug2276.html

Updated

20 years ago
QA Contact: 1698

Comment 4

20 years ago
Finally, for an example of fixed IMG size truncation (as opposed to percentage
image size), please see http://www.prometheus-music.com/gecko/eyeballs.html.

Comment 5

20 years ago
Inserting Milestone info.

Comment 6

20 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
this should be fixed now.  one less bug for ramiro

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 8

19 years ago
Re-opening. While the eyeballs demo works, the HTML test cases in our test case
suite do not appear to be scaling the image (100, 25, 25.999 width tests, both %
and pixel widths), but are disregarding the scaling information entirely.

[see http://slip/projects/marvin/html/img_width_percent.html or http://slip/
projects/marvin/html/img_width_pixel.html examples.

If anyone external reading this bug report and desires access to these test cases
before they're posted externally, just send E-mail.]

Problem occurs on:
	3.9.99 Linux (Apprunner & Viewer checked)

Problem doesn't occur on:
	3.9.99 Mac OS (Apprunner & Viewer checked)
	4.51 RTM (Mac OS)
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: FIXED → WORKSFORME

Comment 9

19 years ago
Its working now.

marking worksforme.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 10

19 years ago
Hi, Ramiro ---

The instantiation of this bug remains in the 3.16.99 Linux build, as defined in
the 3.9.99 comment that I put in the bug.

Should this not reproduce on your system, please just drop by your former
neighborhood and I'll show you.

See ya.

Comment 11

19 years ago
works for me.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M4 → M5

Comment 12

19 years ago
it worksforme, however there is another image scaling problem in test10.

marking assigned m5.
(Assignee)

Updated

19 years ago
Target Milestone: M5 → M6

Comment 13

19 years ago
m6
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M7

Comment 14

19 years ago
m7
(Assignee)

Updated

19 years ago
Target Milestone: M7 → M10

Comment 15

19 years ago
m10
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 16

19 years ago
marking worksforme for real now.

Comment 17

19 years ago
Verified WORKSFORME (technically fixed) on 1999090708 Linux build (RH 6.0/GNOME),
as well as 1999090609 Win32 & Mac OS builds.

There is visual corruption on http://slip/projects/marvin/html/
img_width_percent.html, which I believe is an unrelated compositor problem.

I'll mark this formally verified after I write up the bug (otherwise, I may
forget.)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 18

19 years ago
Side corruption issue broken into bug #13341. This bug is now Verified.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.