All 1.4 builds will install, but will crash on initial startup after installation. Further attempts to run 1.4x results in application crash.

RESOLVED DUPLICATE of bug 205277

Status

--
critical
RESOLVED DUPLICATE of bug 205277
15 years ago
14 years ago

People

(Reporter: lordvader, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425

All 1.4 builds will install, but will crash on initial startup after
installation.  Further attempts to run 1.4x results in application crash. 
Noticed the problem first with 1.4b.  Also happens with both release candidates.
 Running WinXP Pro w/ SP1.  Deleted previous install of Mozilla (1.3.1).  Tried
reinstall with ZoneAlarm disabled.  Still get the same problem.

Reproducible: Always

Steps to Reproduce:
1.Remove previous version(s) of Mozilla and reboot.
2.Run Talkback Fullinstaller for 1.4 (any build).  Application crashes after
install.
3.Further attempts to run 1.4x results in application crashing.
Actual Results:  
WinXP error message asking if I wanted to send a bug report to Microsoft.

Expected Results:  
Mozilla 1.4 should have started running.

Comment 1

15 years ago
You say that you deleted previous install.    Are you absolutely certain that
the directory you installed to is completely empty?   (uninstalling previous
version can leave things behind)

Do you have a specific crash message?  Talkback ID?
(Reporter)

Comment 2

15 years ago
I no longer have the specific message, since I reinstalled 1.3.1.  I clicked to
the technical details of the Microsoft bug report message, but I don't recall
seeing a Talkback ID there or elsewhere.

I did do a full install and also rebooted prior to installing a 1.4 build. 
There was no Mozilla directory when I installed 1.4x.

I may try again later.  When the error occurs, I'll post it. 
(Reporter)

Comment 3

15 years ago
I have two screen captures, but Bugzilla won't let me post the images.

Comment 4

15 years ago
Created attachment 125917 [details]
Error 1

Comment 5

15 years ago
Created attachment 125918 [details]
Error 2

Updated

15 years ago
Severity: blocker → critical

Comment 6

15 years ago
FWIW, the original reporter had the spellchecker and pinball theme installed.

Comment 7

15 years ago
Created attachment 125998 [details]
Error message on Windows 2000

I have the same error on Windows 2000 SP3. The attachment shows the crash
reported by windows. If I press cancel, visual studio starts with the following
call stack:

XPCOM! 610f0769()
XPCOM! 610d7a7e()
XPCOM! 610d831a()
XPCOM! 610d794c()
XPCOM! 610d789f()
XPCOM! 610d627a()
XPCOM! 610b43e4()
MOZILLA! 00410460()
MOZILLA! 00401950()
MOZILLA! 00402f0f()
KERNEL32! 77ea847c()

I installed both 1.4RC1 and 1.4RC2 on top of 1.4b. Both versions have the
problem. If I do an uninstall, and reinstall 1.4b the problem persists.
However, if I do an uninstall, deletes c:\Program Files\mozilla.org\ and do a
reboot, and I can install 1.4b and the problem is gone.

Comment 8

15 years ago
Lars:  That is bug 200651
Mozilla must be installed into an empty directory.

While the symptoms of this bug are similar, the reporter for this bug supposedly
installed Mozilla into an empty directory and is still having problems.

Comment 9

15 years ago
Actually, to be more precise...  bug 195600

Comment 10

15 years ago
same problem here.... win2k, sp3, mozilla1.4 rc2
1.4b did also crash..
1.3.1 works fine....

Comment 11

15 years ago
i tried to unistall 1.3.1, to not uninstall it, to unistall java, but the
browser doesn't start, it crashes before the start for xpicom.dll

Comment 12

15 years ago
But did you install into an *empty* directory??

Comment 13

15 years ago

*** This bug has been marked as a duplicate of 205277 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.