sanitycheck.cgi: Use of uninitialized value in string ne

RESOLVED WORKSFORME

Status

()

Bugzilla
Administration
--
minor
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Ben Caldwell, Assigned: CodeMachine)

Tracking

2.16.3
x86
Windows XP

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

Whenever I run sanitycheck.cgi, the following shows up in my error_log file:

[Wed Jun 18 12:03:57 2003] sanitycheck.cgi: Use of uninitialized value in string
ne at /usr/local/mozilla/webtools/bugzilla_w
cag//sanitycheck.cgi line 405.
Use of uninitialized value in string ne at
        /usr/local/mozilla/webtools/bugzilla_wcag//sanitycheck.cgi line 405 (#1)
    (W uninitialized) An undefined value was used as if it were already
    defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
    To suppress this warning assign a defined value to your variables.
    
    To help you figure out what was undefined, perl tells you what operation
    you used the undefined value in.  Note, however, that perl optimizes your
    program and the operation displayed in the warning may not necessarily
    appear literally in your program.  For example, "that $foo" is
    usually optimized into "that " . $foo, and the warning will refer to
    the concatenation (.) operator, even though there is no . in your
    program.
    
[Wed Jun 18 12:19:44 2003] sanitycheck.cgi: Use of uninitialized value in string
ne at /usr/local/mozilla/webtools/bugzilla_w
cag//sanitycheck.cgi line 405.

Reproducible: Always

Steps to Reproduce:
1. visit the sanitycheck.cgi page


Actual Results:  
error appears in log file

Expected Results:  
no errors

problem does not seem to be having any negative effects on general operation of
Bugzilla.
(Reporter)

Updated

15 years ago
Version: unspecified → 2.16.3
(Assignee)

Comment 1

14 years ago
The line numbers on files change all the time.  Can you please paste the
specific line of code and the surrounding few lines?
Assignee: justdave → mattyt-bugzilla
Severity: normal → minor

Comment 2

14 years ago
Hrm... I can't reproduce this on my bugzilla-tip today.

-M
(Assignee)

Comment 3

14 years ago
I don't believe there have been any significant changes to this code, it could
be caused by changes in your database, so the bug might still be there.

Do you still have a 2.16.3?  Could you let me know the line of code?

Did you make any edits to sanitycheck.cgi?

Updated

14 years ago
Blocks: 231570
(Reporter)

Comment 4

14 years ago
Can't say that I know exactly which line of the sanitycheck.cgi code is the 
problem since this result is appearing in my apache error logs. Other than 
correcting the path to perl in the first line of the file, I have not made any 
edits to sanitychecheck.cgi since checking out version 2.16.3.

I'm currently running two installations of Bugzilla on separate servers (one of 
them is 2.16.3) and the problem still exists. However, on my other installation 
(running 2.17.4), the problem does not exist.

Hope this helps.

Comment 5

13 years ago
I cannot find what this line 405 was. I compared versions 2.16.3 and 2.17.4,
without success. Anyway, I cannot reproduce this bug with 2.19.2+, neither could
mkanat in comment 2 nor the reporter in comment 4 using 2.17.4. So marking as WFM.

If this error message appears again, please reopen this bug *and* write here the
corresponding lines (this would be *very* helpful!).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.