RealOne clips can't be played (.ram files downloaded with filenames that RealPlayer won't recognize)

NEW
Unassigned

Status

()

Firefox
File Handling
14 years ago
10 months ago

People

(Reporter: Toni Mykkänen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

Mozilla 1.4rc2 can't play realaudio clips in amazon.co.uk no matter what. I've
reinstalled RealOne Player, but that didn't help. IE, Opera and Mozilla Firebird
0.6 all open the clip just fine. This happens with all realaudio clips in
amazon.co.uk, but here's one link just to save you from searching a CD with
sample clips:

http://www.amazon.co.uk/exec/obidos/ASIN/B000053GVO/qid=1055959481/sr=1-5/ref=sr_1_3_5/026-9668762-6659646

Clicking a realaudio clip opens an error dialog saying:

Opening hurl.exe
C:\DOCUME~1\MATTIM~1\LOCALS~1\TEMP\hurl.exe could not be opened, because an
unknown error occurred. Sorry about that. Try saving to disk first and then
opening the file.

Funny thing is that realaudio clips anywhere else seem to work just fine, it's
just the Amazon site that seems to have trouble with Mozilla.

Reproducible: Always

Steps to Reproduce:
1. Go to www.amazon.co.uk
2. Find a CD that has sample audio clips in realaudio format
3. Click a song

Actual Results:  
The error above is shown.

Expected Results:  
Mozilla should open RealOne Player just like it does on every other site I've
tried. I know RealOne Player sucks, but that's what Amazon uses and I'm not very
fond of any Microsoft format either...

Comment 1

14 years ago
Added the note for Win-98, Version 1.4

When I am at AtomFilms web site and wish to play a RealOne movie, I see the java
window open with the icon that prompts me to "Click here to download plug-in".
ALl fine and well but the plug in is already in place - be it nprpjplug.dll, or
nppl3260.xpt or nppl3260.dll - all are in place. No need to download, just USE
the blessed thing!  I've certainly confirmed it for myself.  (I can't clear the
"Leave as UNCONFIRMED button.)

Comment 2

13 years ago
*** Bug 222359 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
Jacob, I believe your problem is a different one than the one described here.

Moving to the file handling component and confirming. I see this problem on Mac
OS X with a Feb. 4 build. I realize this is pretty old, so I'll grab a more
recent build and see if it's been fixed since then.
Assignee: peterlubczynski-bugs → file-handling
Status: UNCONFIRMED → NEW
Component: Plug-ins → File Handling
Ever confirmed: true
OS: Windows XP → All
QA Contact: bmartin → ian
Hardware: PC → All

Comment 4

13 years ago
I still see this problem in Mozilla 1.7a on Mac OS X
*** Bug 274118 has been marked as a duplicate of this bug. ***
*** Bug 242595 has been marked as a duplicate of this bug. ***
The two bugs I've just marked as duplicates provide additional examples of
different non-standard and/or "dynamically-generated" links to .ram files that
Moz products download in such a way that the resulting file can't be properly
passed to RealPlayer (or on the PC, can't be passed to the inline Real plugin
and are downloaded; the inline Real plugin doesn't work in any Mac browser and
so all .ram files are downloaded).

Comment 8

12 years ago
This works fine for me in Windows 2000

Comment 9

12 years ago
Does not work with 2005030305 trunk on WinXP SP2
I dont have Realplayer installed and when clickong a music sample link I am not
prompted to install a plugin. Alert box displays something like this:

"C:\DOCUME~1\abc\LOCAL~1\Tmp\18ln7vn0.exe could not be saved, because the source
file could not be read. Try again later, or contact the server administrator."

*** Bug 318664 has been marked as a duplicate of this bug. ***
See bug 318664 comment 2 for a little bit of mac-specific layman's analysis of this.
Duplicate of this bug: 367342
Assignee: file-handling → nobody
QA Contact: ian → file-handling
Summary: RealOne clips can't be played → RealOne clips can't be played (.ram files downloaded with filenames that RealPlayer won't recognize)
Duplicate of this bug: 425263
Duplicate of this bug: 480024
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.