Javascript on this page causes extreme cpu usage.

RESOLVED DUPLICATE of bug 187284

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 187284
15 years ago
14 years ago

People

(Reporter: Curt Jacobson, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

Whenever I go to the above URL, according to task manager, the cpu usage
increase from 3-5% to 50-80%. And this is with an SMP machine. Both cpus go
high. It uses so much cpu that the page scrolls jerky and somewhat unresponsive
some time. Turn off javascript, refresh the page and the cpu usage drops to 3-5%
again. Everytime. Totally reproducable. It seems to have to do with that
scrolling flash scroller. Yes, I have flash 6 installed. When you click on a
link and move to a new page, the cpu usage falls back to normal, even with
javascript enabled. Another reason why I think it has to do with the flash scroller.

Reproducible: Always

Steps to Reproduce:
1.Navigate to page
2.view cpu usage
3.turn off javascript
4.view cpu usage
5.etc.

Actual Results:  
as I described above


Also of interest is that I also have Linux Mandrake installed on this machine
and with Mozilla 1.3.1 and with Firebird 0.6, I have the same issue and it is
entirely reproducable in the same way. The only difference is the way linux
handles the SMP part. One cpu goes high, then it goes low and the other goes
high, and back and forth. At least according to gkrellm.

It was happening in Windows version of 1.3 and 1.4 RC1 also.

Comment 1

15 years ago
This doesn't look to be a JS Engine problem. Most likely Plugins
or Layout. Compare bug 187284, "abcnews.go.com - hangs while viewing".

Reassigning to Browser-General for now. This report is in the same
spirit as bug 187284, and might be marked a duplicate, but I will
let others make the call on that -
Assignee: rogerl → general
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → general

Comment 2

14 years ago
looks like the same thing, and the issue has apparently gone away in more recent
versions

*** This bug has been marked as a duplicate of 187284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.