If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MozillaFirebird forgets Preferences on Gentoo Linux

VERIFIED DUPLICATE of bug 165367

Status

()

Firefox
Preferences
VERIFIED DUPLICATE of bug 165367
15 years ago
12 years ago

People

(Reporter: Konstantin Kletschke, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs to reproduce on Linux, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030617 Mozilla Firebird/0.6

I have a Problem with MozillaFirebird which is hopefully not discussed anywhere 
else. I searched the MozillaFirebird bugs database, but I did not found a bug 
matching my issue and I am postiong it here, because it happens on gentoo, not on 
my debian @work, neither my Girlfiends debian nor my sisters debian. On all three 
debians similair versions tested for good: MozillaFirebird-0.6 and cvs tree.  
  
At gentoo error is on gcc-3.2.3 OR gcc-3.3 AND gtk+-2.2.1 OR gtk+-2.2.2-r1 OR 
Mozilla-Firebird-0.6 OR mozilla-firebird-cvs.  
  
Entering Tools->Preferences shows checkbuttons pressed, but they aren't. Pressing 
it again gives same picture, but after that it is really checked. For example "Open 
Tab in backfound" or Cookie settings. Checking (visually checked) Enable cookies 
enables the three checkboxes underneath it.  
Entering Tools->Preferences again: go 4 lines up and reread.  
  
Question: Am I the only one discovering this? If yes, why? Bad Karma?  
If not, did anybody solve that?  
 

Reproducible: Always

Steps to Reproduce:
1. Tools -> Preferences, there check for example "open tabs in bg" 
2. OK 
3. Tools -> Preferences: Button is NOT checked

Comment 1

15 years ago
-> Phoenix
Component: Preferences → Preferences
Product: Browser → Phoenix
Version: Trunk → unspecified

Comment 2

15 years ago
WFM Mozilla/5.0 (Windows 2000; rv:1.5a) Gecko/20030618 Mozilla Firebird/0.6+

Comment 3

15 years ago
Konstantin, this works fine for me using Mozilla/5.0 (Windows; U; WinNT4.0;
en-US; rv:1.5a) Gecko/20030619 Mozilla Firebird/0.6

Did you already give it a try using a fresh, vanilla profile by calling
MozillaFirebird with option "-p" -> "Manage profiles" -> "Create profile"?

=> adding whiteboard
Whiteboard: needs to reproduce on Linux
(Reporter)

Comment 4

15 years ago
Well that does not help. With MozillaFirebird -P and a fresh Konsti profile its the 
exact same problem. I already made an mv .phoenic .phoenixOLD earlier which 
didn't help either... :( 
Very misterious Bug, what underlying libs could cause it? Or bad shell 
environment? 
(Reporter)

Comment 5

15 years ago
Now using 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030620 Mozilla 
Firebird/0.6 
I realize that right click onto image -> save image as does nothing. 
Is that another bug already or my this be related to "my" bug? 
File -> Save Page as works, but not right click into page -> Save Page As, does 
nothing too. 

Comment 6

15 years ago
Yeap - the "Save image as" is broken currently but that's a different thing, so
let's see if someone else with Linux can confirm your problem...
(Reporter)

Comment 7

14 years ago
Well, today I figured around with it and realized My Firebird was linked against
gtk-1.2. So I compiled it against gtk-2.2.2. With gtk-engines-crux it crashed
immediatly clicking into it, without it worked but same error.
Compile against gtk-2.2.1 it runs with crux eingine but same error.

Where could the error be? Am I stille the only guy whose Firebird forgets
Preferences?

Konsti

Comment 8

14 years ago
nope, you're not the only one. 
i have exactly the same problem.
i am on gentoo, too, and i use mozilla-firebird-cvs, build 5 hours ago.
i compiled it against gtk-1.2, gcc is 3.2.3.
(Reporter)

Comment 9

14 years ago
*phew* I am glad not being the only one :-)
Do you have the Problem on the gentoo with the regular mozilla-firebird-0.6
ebuild too? IIRC I had.
Well, lets see which things will come up regarding this problem, if any...

Comment 10

14 years ago
well, i don't no for sure...
i haven't tried yet, as there are several threads in forums.gentoo.org which
mention "normal" firebird to be very slow sompared to cvs. but i'll emerge and
report it.
stand by!

Comment 11

14 years ago
oh well, the situation is getting complicated...
when i use "normal" mozilla-firebird, it doesn't work, too.
what works is to use mozilla-firebird-bin.
this is precompiled. unfortunately with gcc-2.95. it would be interesting to
know with which flags. maybe we are using too aggressive flags? mine are:
CFLAGS="-march=athlon-xp -O2 -pipe -fprefetch-loop-arrays -ffast-math
-fmerge-all-constants -frerun-cse-after-loop -frerun-loop-opt -mfpmath=sse
-fforce-addr"
btw, i normally use -fomit-frame-pointer, but mozilla-firebird-cvs failed to
start, complaining about a segmentation fault, so i removed this one.
(Reporter)

Comment 12

14 years ago
Hm...
My MozillaFirebird never segfaulted because of -fomit-frame-pointer, because i
use it.
I use
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer -ffast-math
-fexpensive-optimizations -funroll-loops -frerun-cse-after-loop 
-frerun-loop-opt -fforce-addr -falign-functions=4 -msse2 -mmmx -mfpmath=sse"
but the ebuild replaces -march=pentium4 with -march=pentium3 and filters sse2
I use these flags for a long time now, in this time fb began to forget its
preferences. So I thought not to be that being the error, but lets give it a try...
(Reporter)

Comment 13

14 years ago
OK revo, you got it.
I compiled (reemerged) mozilla-firebird-cvs with CFLAGS unset and now it
remembers its preferences! Hell, I did not thought of that...

Comment 14

14 years ago
well, fine!
but now begins the hardest work, doesn't it? we have to find out which CFLAG
might cause the problem to report it to bugs.gentoo.org that the ebuild can be
changed... i suggest i build it for -march=athlon-xp, test again and add one
flag per time till it begins to fail... is there another way you could think of?
(Reporter)

Comment 15

14 years ago
Yes, hardest part of work begins now :-)
I suppose -march=pentium4 with -O2 would work, I will test it tomorrow... So
adding two options at a time and then removing one or the other seems to be a
good way to figure that out for me... There is indeed no help around that. Then
there must be a bug report filed to gentoo to introduce that into the ebuild but
it is a gcc bug in real. Another try would be to compile this with gcc-3.3, I am
curious what that gives. Now I have mozilla-1.4 galeon-1.3.5 and fb-cvs
installed and can't decide, all as fast and responsible (well, galeon slightly
tops it). Is fb displaying sometimes nearly unreadable fonts on your computer
too? Well the big hdd is making it possible to narrow down the bug itself :-)

Comment 16

14 years ago
ok, it is in bugs.gentoo.org now, #23833.
should we discuss it there?

Comment 17

14 years ago

*** This bug has been marked as a duplicate of 165367 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 18

14 years ago
I don't really know. 
But... I think as an compiler bug it is better a quick fix to modify the ebuild,
so lets go there.

Updated

14 years ago
Summary: MozillaFirebird forgets Preferences → http://bugs.gentoo.org/show_bug.cgi?id=23833

Updated

14 years ago
Summary: http://bugs.gentoo.org/show_bug.cgi?id=23833 → MozillaFirebird forgets Preferences
Adjusting summary.
Verifying bug.
Status: RESOLVED → VERIFIED
Summary: MozillaFirebird forgets Preferences → MozillaFirebird forgets Preferences on Gentoo Linux

Updated

14 years ago
QA Contact: sairuh → bugzilla

Updated

12 years ago
QA Contact: bugzilla → preferences
You need to log in before you can comment on or make changes to this bug.