[RFE] Closing the last open tab should really close it

VERIFIED DUPLICATE of bug 156082

Status

SeaMonkey
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 156082
15 years ago
10 years ago

People

(Reporter: Nitin (vfwlkr), Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I use mozilla firebird with settings to not close the tab-bar even if only one
window is open. That works. When only one window is open, the browser looks like
attachement one_tab.JPG

Middle-clicking the only open tab does not close the website. It only hides the
tab-bar. See attachement one_tab_closed.JPG

Reproducible: Always

Steps to Reproduce:
1. Open mozilla / firebird
2. Open any website (www.mozillazine.org)
3. Middle click the tab


Actual Results:  
tab-bar closes, rather than the website

Expected Results:  
either 
- close the browser
- leave browser running, but no website open. (like MS Word when you close all
open documents)
(Reporter)

Comment 1

15 years ago
Created attachment 125994 [details]
one_tab.JPG

Screenshot with one tab open
(Reporter)

Comment 2

15 years ago
Created attachment 125995 [details]
one_tab_closed.JPG

Screenshot after closing the only open tab
(Reporter)

Comment 3

15 years ago
Created attachment 125996 [details]
Expected_2.JPG

Expected Behavior - either #1 or #2
#1: Close the browser
#2: See screenshot of MS Word (Expected_2.JPG) with no document open

Comment 4

15 years ago
I'm sure it can be programmed that way, but why would you want that feature? 

Several workaround come to mind, one of these is to set your home page to
about:blank and click HOME.
(Reporter)

Comment 5

15 years ago
Patrick,

yes, there are easy workarounds: like Alt+F4/Click Cross button to close browser
- which is why i called it a minor bug rather than normal. Changing my homepage
isnt a proper workaround.

Still, I think hiding the tab-bar on middle clicking the last tab is not the
right thing to do, and it should be fixed.
(Reporter)

Comment 6

15 years ago
Possible solution #3 (almost same as #2):
When last open tab is middle-clicked, it is replaced by about:blank

The main reason I'd like to see this fixed is that sometimes you may open some
website inadvertantly (say at work), and want to quickly close it. Middle
clicking a tab seems to be the fastest solution, and should work whether or not
other tabs are open at that time.

This is not a bug, it's a RFE.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Middle clicking on the last open tab does not close the website → [RFE] Middle clicking on the last open tab should not close the website
Whiteboard: DUPEME
(Reporter)

Comment 8

15 years ago
Correcting typo - changing "should not" to "should" in the summary.
Summary: [RFE] Middle clicking on the last open tab should not close the website → [RFE] Middle clicking on the last open tab should close the website
(Reporter)

Comment 9

15 years ago
Updating summary from "middle clicking the last open tab should close the
website" to "Closing the last tab should really close it".

This also happens when you start closing tabs using the X button at the right
end of the tab bar. All of them close one by one, except the last one - which
just hides the tab bar instead of closing the tab.

Summary: [RFE] Middle clicking on the last open tab should close the website → [RFE] Closing the last open tab should really close it

Comment 10

15 years ago
Was gonna file this exact bug/rfe before I found this, have added my vote and
would like to add my comment: i personally favour the suggestion made in comment
#6 (about:blank).  If i wanted to close the window i'd file>close or hit the [x]
but if i want to vlose only the tab id middle click the tab.
(Reporter)

Comment 11

15 years ago
From a mozillazine discussion, looks like TBE does this.
(about:blank on closing the last tab)
http://forums.mozillazine.org/viewtopic.php?t=37895&start=74

(Reporter)

Comment 12

15 years ago
Updated forum url:
http://forums.mozillazine.org/viewtopic.php?t=40604

Comment 13

15 years ago
I'd say that this is a dupe of bug 156082, which also proposes the various
actions upon clicking on the close tab button (as well as some more).
(Reporter)

Comment 14

15 years ago
Agreed. Marking duplicate opf bug 156082

*** This bug has been marked as a duplicate of 156082 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 15

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.