Closed Bug 209960 Opened 19 years ago Closed 19 years ago

Keyboard focus shifts to search field even if you're in the process of typing a URL

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: mozilla, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Found similar bugs, but none addressed this issue specifically.

The problem is most prominent the first time Mozilla is run after a reboot,
since it takes a bit longer to start.  If you highlight the URL and start typing
in a new one, as soon as the page finishes rendering the cursor will jump to the
search field in my example page, google.

This is the main reasin I switched from IE, and previous versions of Mozilla do
not exhibit this behavior.

Reproducible: Always

Steps to Reproduce:
1.Open browser
2.Highlight URL
3.Begin typing

Actual Results:  
Half of URL ends up in search field of google

Expected Results:  
When user begins manually entering a URL in the location bar, the browser should
ignore operations that switch focus to the primary text entry field of a page.

All configuration options are defaults.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified DUPLICATE 2003-ß9-03
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.